Buderus WLW196-i heat-pump

I am using a Buderus WLW196-i. This type has a integrated lan-gateway ( similar to KM200). Using the KM200-Bindig, the Heat-pump is discovered, but communication fails. I think, there is a problem with the private key. I have the loginname and password from the heat-pump (label), but there is no private password. Has anyone expirience to deal with that, or is there another solution?
kind regards erich

Did you read about JCE ?

yes, i did and installed the two additional jar´s with reboot. (i am using ZULU-11 on WIN10-System)
2021-06-10 13:38:39.912 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler KM200GatewayHandler tried updating the thing status although the handler was already disposed.
2021-06-10 13:38:39.927 [INFO ] [internal.handler.KM200GatewayHandler] - Update KM50/100/200 gateway configuration, it takes a minute…
2021-06-10 13:38:40.177 [WARN ] [b.binding.km200.internal.KM200Device] - Parsingexception in JSON: com.google.gson.stream.MalformedJsonException: Use JsonReader.setLenient(true) to accept malformed JSON at line 1 column 12 path $ service: /gateway/DateTime

p.s.: Encryption is ok:
“C:\tmp>“c:\Program Files\Zulu\zulu-11\bin\java” CipherTest
Max AES key length = 2147483647”


I’ve got more or less the same pump. Do you ‘create’ the correct private key?

There is a link and description.


I have read all that stuff. but the problem is,that i have no “PrivatePassword”! for a gateway because there is no expizit extra gateway - it is a builtin one. The Android-App connects via the “BOSCH-ID” and that password seems not to work in the KM200-binding. I mention, the authentification is a little bit different to the KM200.

Yes, it’s the same machine here. The gateway is built in. It’s some time since I installed it. But I think the password is the same as you can find in the system menu under ‘internet’. The second step is to descramble the private key (link above).
But I can have a look tomorrow or at the weekend in my config files.

Ok, second try.
Go to AES-Key-Generator für das KM200 Web Gateway and insert the PW shown in the “internet” menu of the pump and your Bosch-App Password.
If this will not generate the proper secret key I´ll have a look at the weekend.
Hope it helps.
Best regards and good luck.

Ok, now i got it. The password is not displayed in the “Internet-Menu” There is only the option to reset the password. So i reset the password and had to reinstall the App to set a new password. Now i generated the AES-Key with this new password and it works. Thx!

1 Like

Hi there,
I am running the km200 binding in a docker container and also had the issue with “no communication possible”… I tried so many things, what in the end worked was easy so I wanted to share:

As your “Internet Password” or private password, please do use a very simple password, I am not sure wether upper-case letters are supported and for sure no !?#.,-_ etc. I simplified my password and suddenly it worked.

Many thanks though for all posts here that helped me find check various possible issues!

Hi @kaper25
I wasn’t aware that the KM200 binding might support the WLW196.
So thank’s for creating this thread (and to Joe for reviving it :wink: )

Since I’m interested in that heatpump too (not ordered yet), I’d like asking you about your impressions/experiences of this integration:

  • Would you share a list of channels you get from the KM200 binding talking to your WLW196?

  • Does the integration/communication via the binding work reliably?

  • Are you controlling/changing operation of the heatpump somehow from openHAB side (e.g. force usage of PV surplus) or are you just monitoring the heatpump?

Many thanks,

The Website has changed. Here the new link: