Bulbs causing zibee binding to become unresponsive

Tags: #<Tag:0x00007f433dc4df60>

I’ve spent quite a bit of time now working with openhab and zigbee and I think its great and works really well until it doesnt.

I’ve determined all my issues currently stem from the use of zigbee bulbs and the way the zigbee binding handles them

I am running 2.4.0 with an ember controller

the bulbs I am using are philips Hue (multiple models) sengled (multiple models) and Feibit ( FNB56-ZCW25FB1.6) all have one thing in common they all report zigbee_powermode RECEIVER_ON_IDLE

which as far as I can tell causes the binding to believe that the device should be on the network and able to be polled 24/7
unfortunately this is not the case as the bulbs are connected to traditional mechanical switches which are getting turned off

once few bulbs are unreachable on the network the logs fill with entries like these and commands start to slow down say turning on a zigbee light switch normally is instant but after these logs appear it takes up to 3 minutes to switch on. if I turn on every mechanical switch that controls a smart bulb in the house the errors clear and the network response times go back to normal.

2019-03-31 07:56:46.854 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE18140334B79B: Node SVC Discovery: request NEIGHBORS failed. Retry 3, wait 6660ms before retry.
2019-03-31 07:56:46.854 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE181403503029: Node SVC Discovery: request NEIGHBORS failed. Retry 3, wait 6978ms before retry.
2019-03-31 07:56:46.985 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE18140334BB69: Node SVC Discovery: request NEIGHBORS failed. Retry 4, wait 8808ms before retry.
2019-03-31 07:56:50.658 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 0017880104A3DFC4: Node SVC Discovery: request ROUTES failed. Retry 9, wait 13140ms before retry.
2019-03-31 07:56:53.329 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 0017880104A3E02A: Node SVC Discovery: request ROUTES failed. Retry 4, wait 4316ms before retry.
2019-03-31 07:56:53.341 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 0017880104A3DF76: Node SVC Discovery: request ROUTES failed. Retry 4, wait 4488ms before retry.
2019-03-31 07:56:56.866 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00158D000205E2E6: Node SVC Discovery: request ROUTES failed. Retry 7, wait 4300ms before retry.
2019-03-31 07:56:56.866 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE181403501EB3: Node SVC Discovery: request NEIGHBORS failed. Retry 4, wait 4500ms before retry.
2019-03-31 07:56:56.876 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE18140350210A: Node SVC Discovery: request NEIGHBORS failed. Retry 4, wait 6495ms before retry.
2019-03-31 07:57:00.671 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00158D00020097E4: Node SVC Discovery: request ROUTES failed. Retry 6, wait 13620ms before retry.
2019-03-31 07:57:03.526 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE18140334B79B: Node SVC Discovery: request NEIGHBORS failed. Retry 4, wait 6660ms before retry.
2019-03-31 07:57:06.880 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE181403503029: Node SVC Discovery: request NEIGHBORS failed. Retry 4, wait 11630ms before retry.
2019-03-31 07:57:06.885 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE18140334BB69: Node SVC Discovery: request NEIGHBORS failed. Retry 5, wait 4404ms before retry.
2019-03-31 07:57:07.655 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 0017880104A3E02A: Node SVC Discovery: request ROUTES failed. Retry 5, wait 4316ms before retry.
2019-03-31 07:57:10.682 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 0017880104A3DF76: Node SVC Discovery: request ROUTES failed. Retry 5, wait 13464ms before retry.
2019-03-31 07:57:13.351 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 00158D000205E2E6: Node SVC Discovery: request ROUTES failed. Retry 8, wait 19350ms before retry.
2019-03-31 07:57:13.537 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - B0CE181403501EB3: Node SVC Discovery: request NEIGHBORS failed. Retry 5, wait 6750ms before retry.

if there was an option to set the thing to be zigbee_powermode RECEIVER_ON_PERIODICALLY (or behave like it was) where they are not polled constantly my network would not lock up

or even better if the thing went into a offline state after not replying for x amount of time so that it doesn’t get polled until it next initiates communication or a command is sent by the user selecting an option, that would resolve this issue

There have been a lot of upgrades to the Zigbee binding since 2.4. All of my bulbs (GE Link) would drop almost daily! Using the latest binding has pretty much eliminated the drops. You can still use OH 2.4 with the latest version of binding. This script (or the manual install instructions) may be helpful…

ill give it a try and see how i go

well seems that you are correct the new binding does fix this, atleast at the moment it seems to Ill se how i go over the course of a few days

1 Like