Calling all z-wave Fibaro Dimmer 2 users

Agree the Dimmer 1 and 2 are different devices completely (1 is leading edge only) and paramaters are not compatible.

I was just wondering if there might be some “hidden” parameters (i have tried and tried again with the parameters from the manual), knowing that my brother has a working solution with a dimmer 1 and the same LEDs as me makes me really hope that there is a combination that works but so far to no avail.

I have 4 x 12w LEDs on the circuit - I would have thought this was close enough to the 50w min to not need a bypass?

In testing, I also added a 60w fillament bulb to the circuit with no difference in result - although this may not be a good test as this mixes lighting types.

Sometimes it helps to reset the device (or set all parameters to default according to the manual) and start a fresh approach … :sunglasses: :grin:

yep tried a factory reset with same results. Insterestingly I changed the dimmer to forced leading edge and the dimming scale is more accurate and they dim a lot lower however the light isnt stable at a low dim - not a flicker, but a slight in up and down. My LEDs support leading or trailing but the fibaro detects trailing and I though this was what LEDs should be dimmed with.

I’d agree - trying one or more manually forced auto-calibration of the load type is worth a try before resorting to Bypass 2 or rewiring from 2-wire to 3-wire BUT don’t expect too much.

To paraphrase the Fibaro instructions:
Force the calibration procedure via B-button menu (red LED indicator) or by setting Parameter 13 - Force auto-calibration to:
1 for force auto-calibration of the load without Fibaro Bypass
2 force auto-calibration of the load with Fibaro Bypass

In OpenHAB 2 (and probably 1), you can see all the parameters reported by a Z-Wave device by looking for the nodexx.xml files (my install uses /opt/openhab/userdata/zwave).

As well as what the device reports, and the Fibaro manual, there’s also the pepper db, which has two entries for the FGD-212:

Unlike OpenHAB1 which needs you to define parameters, OpenHAB 2 uses a user-submitted database of the device XML files to auto-discover kit. Chris maintains the device list here:

OpenHAB 2 is in active development at the moment with several Z-Wave issues being worked out so I’ve not managed to experiment with the FGD-212 max/min parameters to perfect my own install yet.

Just to manage expectations, a forced auto-calibration has helped one of my Fibaro FGD-212 work better after a change of bulb type (confused the intelligent dimmer as it checked for problems) BUT repeated calibrations hasn’t changed the outcome where dimming was poor, or the load switched off immediately.

For me, a dimmer with the ‘perfect’ install of a 3-wire connection, auto-calibration, and several different brands of good dimmable LED bulbs, still gives poor remote control and dimming.

Increasing the load by mixing one incandescent bulb with LED bulbs in multi-light fittings sadly didn’t help me (old trick which worked with 2-wire X-10 devices).

Adding FGB-002 Bypass 2 units also made no difference what so ever with 3-wire power (L and N to the module) and multiple LED bulbs on the edge of the minimum 2-wire load.

Worse, switching the light on remotely via Z-Wave often results in the light starting to dim up from zero, stop, and turn off again. A second attempt to turn is usually successful but makes scripted control harder.

Local manual switching has been more reliable - the manual suggests there are different calibration parameters for local and remote control to compare and tweak although I’m currently diverted testing OpenHAB2 rather than tweaking the FGD-212.

My opinion is the additional complexity of auto-calibration, load sensing, and Z-Wave Plus (including secure commands not yet supported in OpenHAB) has gone too far with the FGD-212 when all you want is a light to turn off and on!

I totally agree that this dimmer is far too complex for someone who just wants to switch on-off the lights. I’m facing this crazy thing where the dimmer goes on and then off immediately after 1 sec. That happens after I changed the bulbs and tried to run auto-calibrate. I have two bulbs, total load 67 watts with OH-2 b3. I’ve tried removing and then adding the node to force calibration. Tried to auto-calibrate using parameter 13 but I get an error “ERROR 404-Not Found” while other parameters seem to work fine. The log message I get is :

Received HTTP put request for update config … for the unknown thing xxx.

I wonder how is that unknown since I can see all parameters…

I’d appreciate if someone could bring some light …

Thank you,

Annoying, isn’t it! I understand the dimmer detects higher than expected switch-on current, assumes an overload fault, so turns the light off again for safety.

For me, turning on with a physical switch was more reliable than Z-Wave remote control perhaps as the dimmer uses two different sets of parameters for local and remote control (more complexity!). Both methods of control were more reliable after repeating auto-calibration.

From my experience, excluding and re-including the dimmer from the Z-Wave network doesn’t alter the auto-calibration - load and network config appear separate.

Changing bulbs didn’t do much for me, but setting Parameter 13 to Force auto-calibration did improve ON reliability.

OpenHAB2 doesn’t reliably control my 7x FGD-212 dimmers at the moment so am unable to test fully, but here’s what I did to manually force recalibration:

  • OpenHab2
  • PaperUI
  • Configuration -> Things
  • Don’t click on the device FGD-212 Thing itself! (goes into Channel / Item not Thing config)
  • FGD212 Fibaro Dimmer 2 -> black Pencil Icon (on the right next to the Delete bin)
  • Configuration Parameters
  • 13: Force auto-calibration -> dropdown menu (select one…):
    ** readout
    ** force auto-calibration of the load without Fibaro bypass
    ** force auto-calibration of the load with Fibaro bypass
  • Select the Blue Tick at the top
  • Message ‘Thing Updated’ appears

If that sounds like what you did without success, try the physical button and coloured LED process as described in the Fibaro Manual:

After that, all I can think of is to roll back to a dumb incandescent bulb larger than the minimum load and try again.

For my own kit, I’m back to manual switch control only. Swapping network stack from Z-Way for RaZberry to OH2 was likely a Bad Idea™ by as it may have confused matters by introducing the work in progress support for Z-Wave Plus secure association.

I hope to go back to basics by bench testing factory reset FGD-212 under OH2, perhaps without a networkKey in the binding.

1 Like

I had to reset twice and then exclude from controller. In the meantime I had initiation failures, half working device ,etc. Now I wish that my bulbs will never die otherwise next calibration will be done by me manually, using a hammer… :sunglasses:

Now I have a fully working device meaning I can activate the lights by both physical switch and over OH2.


Really appreciate for your step-by-step process. I’m sorry for the noob question but how to manage the network key + secure association ? I do have a Z+ Aeon stick but my devices are mixed Z+ and plain. I have default settings meaning Secure Inclusion Mode = ‘Entry control devices’ with a default network key. Due to the beta phase it may not be ideal to use secure inclusion ?

thank you !!

Interesting! It helps to know that it’s not just me seeing failed association attempts, dimmers that turn on but not off, and other horrors.

It’s even better that you managed to get a FGD-212 working without the use of that hammer! :wink:

From what I’ve seen power outages and replacement bulbs don’t alter the calibration once done.

As for the network key, I tried copying one over from Z-Way (networkKey in /opt/z-way-server/config/zddx/*) into:

PaperUI -> Configuration -> Things -> Z-Wave Serial Controller -> Pencil -> Configuration Parameters -> ‘Network Security Key’

Others have set this to get locks working with OH2 secure inclusion, but I’m yet to get a FGD-212 fully working with a key set.

When you got your dimmer 2 working, did you have a ‘Network Security Key’ configured in the binding please?

I don’t know if the OH2 Z-Wave binding generates a key itself if it is unset and the device supports ZW+.

Wow sounds like a lot of issues with the 212’s
I found that leading edge was better for LED dimming, but produced overload issues where the lights would randomly turn off - sometimes triggered from turning on a CFL somewehere nearby that has nothing to do with the z-wave mesh.

I have decided to live with running trailing edge and not being able to dim the LEDs very low and have poor control over the dimming levels. This has provided a stable experience, albeit not fully utilising the dimming capability of my LEDs

Well yes there was one. I never dealt with that as I was not interested in having a secure connection with any device. What triggered me though to ask about security is that dimmer exchanged messages for security which I didn’t really understand.

My general impression about z-wave is you must make sure that initialization must be fully completed before you start using the device. I run several times into an endless loop of useless actions because the device appeared fine (full configuration parameters, association groups, neighbors, etc) but when trying to fire a command or change a parameter it never reached the device or was half-working. Checking the debug messages you can notice that initialization is stuck and get repeated messages, retries exceeded… etc. I mention that because it was part of the problem with my dimmer. I saved my life with Aeon stick which allows inclusion side-by-side without using openhab or any other software.

Well he’s an interesting development. I was reinvigorated to fiddle some more after reading some of the replies.

I set my dimmer to forced leading edge and again my lights randomly turned off and I lost control of the toggle switch for some time. I tried increasing the overcurrent paranater to 350 and there was no difference in behaviour.

I then set that paranater to 0 to disable overcurrent detection and they have been working flawlessly for two days now. I have full range dimming which reflects what you do on the slider in openhab

1 Like

Just got a Dimmer 2 and connected two Ikea dimmable LED bulbs but they just keep producing an annoying humming sound. Tried adding the bypass 2, fiddling with parameters to no avail. Then I contacted Fibaro support and they suggested I upgrade the firmware on the dimmer. When I asked for instructions to do so they replied that it was only possible through Homecenter® citing some security/confidentiality related mumbo-jumbo in order to justify not having a tool for the rest of their clients (the vast majority I guess)…
They also suggested trying different bulbs, one would guess Fibaro to want Ikea bulbs to work with their product…

I guess I will be returning the dimmer 2

As the not proud owner of six FGD-212 devices, all with v3.2 firmware, news that Fibaro is refusing to support firmware updates with non-Fibaro controllers is very annoying.

I thought Over The Air upgrading (OTA) was a standard feature added in Z-Wave Plus. If Fibaro have used their own vendor extensions for updates they have really killed the spirit of interoperability at the heart of Z-Wave.

@federic0 - do you know the version of firmware your device has please?

After much searching around multiple OH2 and other Z-Wave controller forum posts, there seem to be multiple reports of firmware v3.2 being very difficult to pair, and also poor dimming configuration. v3.3 seems to have better load detection, with v3.4 firmware mentioned in Fibaro manuals.

My FGD-212 v3.2 don’t associate easily with OH2, and even after a struggle (exclude/ factory reset/ include), they don’t give Z-Wave control. Even local control via the hard-wired switch can be unreliable, but after trying a few different types of LED bulbs, they mostly turn and off via the local switch, that is after several manually forced re-calibrations (see previous post).

I can (slightly) forgive Fibaro for problems dimming LED bulbs as their internal design varies very widely. This BigClive video gives an idea of the challenges, and very different power supply circuitry used in otherwise identical bulbs:

I would list the bulbs that have worked for me, but in all probability, a later production run might have a different power supply and fail to dim!

The last resort for control seems to be to change Parameter 30 Load Control Mode to manually set leading/ trailing edge control, but personally, I’d try another LED bulb type or the old X-10 hack of installing a incandescent bulb along side LED bulbs to increase the load current (cheaper than a Fibaro Bypass 2 for testing).

On the other hand, I can’t forgive Fibaro for the Z-Wave protocol issues. Ongoing diagnostics by @chris in another thread suggests the only fix is new firmware or a workaround in every Z-Wave controller software stack:

It looks like other Z-Wave controllers have added hard-coded workarounds but it looks like a test for both device and firmware version would be needed.

I’d much prefer to simply update the Fibaro firmware and fix the root cause.

@FloatingBoater, it turns out my device is already at the latest firmware, 3.4, however, tech support at Fibaro was asking me to update, all though I had sent my current version… They also requested I change parameter 6 to 0.003, which is not in the allowed range, however, I think they meant 3ms which would be achieved by setting the parameter to ‘3’. I have tried all their suggestions but my bulbs still produce the same humming noise and dimmering is very subtle to say the least.

It’s been around a while - longer than recent Z-Wave Plus additions, but yes, it is part of the standard.

I very much doubt that they have used a different extension. I’m pretty sure they are using the standard command class for this - I’ve been looking at this a little recently with a view to adding support, but, as you’ve found, it’s complicated…

However, I believe it’s complicated not because manufacturers are using non-standard protocols, but because Fibaro, and possibly other manufacturers, are not supplying the firmware binaries unless you use their hardware (ie for Fibaro, they want to to shell our $$$ for the HomeCenter!).

That’s my understanding of the problem following some recent investigations, and preliminary discussions with Aeon about their firmware updates (which are currently only available under NDA)… I tried reaching out to Fibaro recently, but didn’t get any response! (on the other hand, I can’t say enough about how good Aeon support is!!)

I have two dimmer 2. One of them has connected 6 halogen bulbs and works pretty good, no noise and good dimming range, smooth on/off and the 2nd one has 6 leds and is buzzing like hell :frowning: Tried already to switch the dimmers between them and same fart, i get this stupid noise!
On Fibaro forum if you ask this, they will ask you if you have tried the bypass, no, i didn’t because i have around 30 w power consumption, than nobody knows…
don’t know what to do to loose the noise with dimmable leds.

Apart from trying different LEDs (which is far from guaranteed to work), an old workaround is to swap one LED for an incandescent bulb in a parallel light fixture.

This both increases the load (cheaper than a Figaro Bypass 2), and gives a more resistive load which can give better low-level dimming to all bulbs in parallel. I think Fibaro quote 50W as the minimum - which is a lot of LED light!

I used to use this hack with 2-wire X-10 controllers, and although it is less useful with 3-wire installations it is still worth a try.

I have seen another post discussing buzzing, but don’t think a fix was found.

My own FGD-212 now pair and work with the latest OH2 build (took a further round of exclude/ factory reset/ include), but this is without secure mode, and the lights still need tweaking to fix the tendency to turn off immediately after a ON command, requiring several attempts.

Still, the changes working around Fibaro’s firmware issues are yielding results, which is great. I’ll report back with any conclusions with leading/ trailing edge or overload detection settings with my LEDs.

I’ve just fitted a fibaro 212 with bypass, and it’s working great in openhab.

Weirdly though it won’t switch with the manual switch (standard on/off) that’s attached to it. Does anyone have any ideas please?

Thanks in advance.

  • Have you checked the switch is wired between S1 and Sx (e.g. not S2)?
  • Has the device correctly detected the switch as momentary or toggle?

I’d recommend replacing an on./off switch with a momentary switch to allow set dimming, or at least set the switch to off and manually turn it on and back off to simulate a momentary contact.

Thanks James.

The switch is wired correctly and i’ve used habmin to tell the device it has a toggle switch attached, but to no different effect.

When i get some time I’ll try a full reset making sure the switch is off (it might not have been when I did it before). Hopefully that’ll sort it.