Can not find configuration files for KNX

Hello everyone!
I have started a school project with Raspberry Pi 3B, KNX and Amazon Alexa.

I tried installing the Openhabian system on my raspberry, but always ended up with the same error no matter how long I waited or how many different methods I tried.
In the end I ended up going for raspbian and installing the OpenHab2 software manually. It works till this part.


  • I am unable to find KNX configuration files as every tutorial describes it. Where are they? (keep in mind I installed the software onto Raspbian)

  • I’ve connected my KNX hardware with openhab via the “Things” tab. It shows the KNX system is online even if disconnected. IS that okay?

Any other tips or tricks?

Hello Tilin,

“the same error”: i can only guess… :slight_smile:
My experience with OpenHAB running on a Pi: Patience and several reboots helped … always.

The (KNX) configuration files: they only exist, if you write and store them. This (new) PaperUI System stores configuration details deep in the system. (You will find discussions about this mechanism here in the forum.)

I’m curios: what KNX Devices are you using? (Electrician nearby?)

Best regards!

Hello @rrichard
We attempted to redownload the system and reboot several times and it didn’t work.

I’ve figured out why there were no configuration files and it was due to me using KNX binding 2.x, not 1.x.
Currently I am unable to connect the KNX with openhab2 and really am struggling with it.

We’re using the Zennio KNX IP-Interface for the connection to the router and we’re also using a Zennio KNX MAXinBOX 8 Plus, as well as a Zennio KNX DIMinBOX DX2. This is all school hardware.

Hi Tillin,

what is the goal of your project? Installation of KNX <-> OpenHAB or perhaps implementing some “smarthome” functions with the given setup?

There are some hurdles getting the the system together … yes.

Perhaps you can describe your project goal, your given tasks, your existing support and your school form.

Or you asked specific questions while you are working. E.g. using this modell device, this existing configuration (KNX group addresses), done that, this log output, your question … and so.

Best wishes