Can not see openHAB on LAN

I installed openHAB (1.8.3) a few days ago on my iMac. I started with two WeMo switches and everything works great, BUT, the only way I can access the GUI is through my iMac browser and the address “http://localhost:8080/”.
I setup the openhab.cfg as follows:
I can not see this IP address in my router as being used. Is there something in my iMac setup that could block it from getting out to my LAN?
Any help is greatly appreciated!


I don’t know Macs that well but it sounds like you have a local firewall that is refusing connections on the needed ports.

Hi Rich,

thanks a lot for the feedback. I turned the firewall on my Mac off, but no luck.
I am surprised that other Mac users did not run into that problem.
I know I am doing something wrong, but I don’t know where to start digging…

Anybody out there have any ideas?


It’s difficult to know without more details about your problem, but you may be seeing an issue with IPv6 (vs IPv4) addresses not matching the security:netmask. Also, is security:netmask really set to nothing in your configuration or was the post just not formatted correctly?

Hi Steve,

thanks for the feedback! The security:netmask was not shown in my post correctly due to the cut and paste.
It is actually commented out, meaning the default mask was active.
Here is my config file:

</># Configuration folders (must exist as a subdirectory of “configurations”; the value
</># tells the number of seconds for the next scan of the directory for changes. A
</># value of -1 deactivates the scan).
</># A comma separated list can follow after the refresh value. This list defines a filter
</># for valid file extensions for the models.

</># configures the security options. The following values are valid:
</># ON = security is switched on generally
</># OFF = security is switched off generally
</># EXTERNAL = security is switched on for external requests
</># (e.g. originating from the Internet) only
</># (optional, defaults to ‘OFF’)

</># the Netmask to define a range of internal IP-Addresses which doesn’t require
</># authorization (optional, defaults to ‘’)

</># The name of the default persistence service to use

</># The refresh interval for the main configuration file. A value of '-1’
</># deactivates the scan (optional, defaults to ‘-1’ hence scanning is deactivated)

</># Bind service discovery to specific hostname or IP address

Thanks in advance,

Underscore really there?
I don’t think this parameter is doing what you expect, anyway. Is there some reason you have not left it as default?
What is your iMac IP address?

Sorry, no underscore of course, I am new here, and the formatting, when posting, is kicking my butt…
My iMac IP address is
The default config is and I thought I need to set it to something else, so that I can access it via iPhone app when at home connected to my LAN. That was my intention, so that I can change switches using the app.
I can access the openHAB GUI using my iMac and browser by connecting to: http://localhost:8080/ This works great and I can change switches that are connected to my WIFI (WEMO switch). So in general the openHAB stuff is running fine.

When I look at my router and check for attached devices, I can not see the IP that I typed at the service discovery:bindaddress line in the config file…
I have been googling and reading quite a number of posts here but no cigar…


The are many possibilities and the information so far doesn’t narrow it down much. A few questions…

What happens when you try to access openHAB locally from the iMac using instead of (locahost)?

What happens when you try to access openHAB from an external device? Are you seeing an error message? Does it hang and then timeout? Something else?

Have you been looking for any related information the openHAB log file when you try to connect from an external device?

Your Openhab lives in a box that already has an IP address (your iMac). That’s where your phone app needs to look for it.
You cannot tell Openhab to use some other IP address instead, that is not what that parameter is for.
I’m not entirely sure what it does do! Something about how Openhab itself tries to discover things in its environment I think, best to set it back to default.

Bingo!! You two paved the path to access! Thank you very much, I am in.
Two things I did wrong:

  1. In the openhab.cfg I needed to leave the servicediscovery:bind_address commented out (i.e. at its default
  2. Access the openhab application via (i.e. use of the IP address of my iMac on the LAN, and since my sitemap name is “default” I do not have to specify it).
  3. Using this URL in the iPhone app under the “Remote URL” setting grants me access!!!

Again, thank you for being persistent in asking questions to narrow down the issue helped tremendously.


That’s great. Typically, one would put the LAN address in the Local URL of the iOS app. The Remote URL is used for WAN/external access (usually via my.openHAB).

That’s what I thought as well, but when I did that I got the following error message:
Error: Request failed: unacceptable content-type: text/html

So I left the local blank and put the URL string in the Remote and voila, it worked…