Can someone confirm CalDAV-personal Switch works?

Dear all,

I have troubles getting a Switch associated to a Caldav-personal calendar running, see CalDAV personal: Switch item is always delayed for ON, on time for OFF

To avoid you have to read the whole post, I created this topic to quickly ask for a simple test:
Could someone confirm that the Switch works and is triggered ON and OFF on time for you? (If you have the time, please put your code as well…)

Thanks a lot! And Happy New Year ! :smile:

Guys, am I really the only one who tries to use it?

Yep, works for me
You need to wait for potential users of your particular binding and use case to log in, young man.
Easy on the language, thanks.

Corrected. Sorry, and thanks for the feedback…

If someone comes across this thread and has some minutes: Please provide a code example of a calendar switch working for you. Maybe I simply did a stupid mistake somewhere…

This is not really related to this, but I had problems with the CaldavIO, displaying events in OH. It worked sometimes after restart, sometimes after item reload/refresh, but was never realiable (usually it showed nothing).

The problem was, that I had to specify ‘usedCalendars’ in CaldavPersonal.cfg also. I don’t know, this seems really stupid for me, because firstly I thought the CaldavPersonal only matters if you use it for to toggle switches (like you want to).
But the comment says this in the config:

Can also be used to show upcoming or active events

So I would suggest to you that, try looking over and over your config and docs. Also try to delete the downloaded ics files from OH and clean cache, maybe that can help (you have to delete the ics-s manually, clean cache wouldn’t do this - again, I don’t really understand why cache clean didn’t delete these files…).

The problem was, that I had to specify ‘usedCalendars’ in CaldavPersonal.cfg also.

I specified it in CaldavPersonal.cfg only. Could this be the issue? Where should I put it as well?

you have to delete the ics-s manually

I did. Also, the import process from the CalDAV server seems to work perfectly, so the ICS files should not be the problem.

The issue is probably related to the scheduler and the execution of the jobs.

Could someone post a working example for the Switch driven by CalDAV-personal? I am lost.

Update from my side:
I changed nearly everything.

  • I changed the CalDAV caldendar provider
  • I started with a completely fresh setup on RPi
  • I also tested a setup on an x86 PC using Xubuntu Linux

Same result.

@vzorglub: Which is your reloadInterval? Is it possile that you use very frequent server updates, say one minute? This would always trigger the Switch to ON during the updates and hide the issue… (By the way: I use this as a workaround, but it is ugly as it causes server and network load)


# Reload interval unit is minutes. 
# Defines how often the calendar should be reloaded from server.
# Default is 60 minutes

# This defines which events are relevant for execution. Unit is in minutes.
# Default is 1 Day (1440 minutes)

@vzorglub: Thanks a lot. So obviously my idea was wrong :frowning:

I found two other discussions with the same issue, but both are unresolved and the authors seem to be inactive:

and here: