Can’t get myQ garage door opener to work

I’m new to this and trying to set up a new system. I’m running OH 3.2 on a raspberry pi. I have been able to set up 8 Kasa smart switches and a couple of smart plugs through Alexa. Also the openWeather binding works for me.
I cannot get the Chamberlain MyQ opener to work. I’ve installed the binding and the bridge. The bridge to my account says it is online. But I’m still unable to control the door which just gives me the status of unknown. The only parameter that the thing wants is the serial number which I got and verified several times from the back of the myQ device.
But I just noticed that the parameter asks for the serial number of the garage door opener but that can’t be right. I have an older craftsman opener that doesn’t do wifi.
The serial number on the back of the device differs from the number in my myQ app(which works) by a prefix of “GW”. The openHab binding doesn’t work with or without the prefix.
I tried removing and reinstalling the binding but no change.
I just don’t know what to look for or try. Any pointers would be appreciated.

Never mind… I clobbered the thing and items and re-added them via a scan/discovery. That seems to have fixed it.