Cannot access anything in Openhab after widget creation

Hello everybody,
i yesterday started from scratch with OH3. Looks really great and gives me an opportunity to make a huge step forward with my Home Automation.
Today I started to create my first custom widgets on the overview page.
I was changing something directly in the YAML.
I did a little bit of trial and error, but when i thought i had the solution, i could not access anything in openhab i already cleared browser cache and tried another browser, no difference. I also restarted Openhab and the raspberry. See the gif here:
I also cannot access anything from my iPhone.
Is there any possibility to delete my Widget-Try around? Otherwise i would need to setup Openhab completely new, which i am not absolutely interested right now.

I am running Openhab on a Raspberry 4 with Openhabian with a fresh install yesterday.
The OpenHab Log is still running, so i assume, there is somewhere just a broken file.

Edit: i can still control items via the REST-API with my iPhone shortcuts…

Hi @flattermann

what exactly did you changed? Changes to the YAML structure of pages and/or widgets shouldn`t influence the whole environment normaly.

You could change the created YAMLs (which gets converted to JSON in the database) here: ‘/var/lib/openhab/jsondb/’ as well as the backup folder here: ‘/var/lib/openhab/jsondb/backup/’

I think you have to stop openhab for this, do your changes and startup openhab again then, to apply your changes.

But as I said above, I don’t think that a change to the YAML of the overview page has this impact on the whole environment - but I could be wrong.

Hey @RGroll

i was just experimenting with the accordion function and this was the only thing i was doing in openhab. I deleted the complete section in the overview page but nothing changed…

When I try to access the setting page directly via http://IP-Adress:8080/settings/ i get a 404 Error.
Openhab is also still running. The Log is bringing in all the information.

Hmm, sadly can’t give you any other tips here then, besides using the widget editor next time to experiment with the vue-components :slight_smile:

Accessing the settings page directly is not possible. This returns a 404 in my case too.

Regarding your shortcuts for the API access. Have you tested them before on OH3? Since OH3 the API access is only possible with an access token which can be created on the user settings inside page. So shortcuts from OH2 must be modified.

I’m not sure if all of your behaviors are refering to the same issue.

Accessing the settings page directly should be working with this URL: http://IP:8080/#!/settings/

i just adjusted my OH2.5 iOS Shortcut to the new item-name, is i switched completely to browser configuration and item names changed.
And my light is going on and off as expected.

i missed the “#!” this opens the settings page, but i still cannot click anything…

You are right, thanks for the hint. For me this never worked but I run OH behind a reverse proxy. Without it is working. I think i have to investigate on my nginx :wink:

Okay i finally restored everything.
I created something in the “mansory” section.
First i deleted that section completely, that did not work.
no i have in the uicomponents_ui_page.json only

"mansory": [

Thank you for your help and this was the last time i tried to run trial and error in the overview pages.
This issue was very close to decrease the WAF of the holiday project OH3.

Wishing everybody a merry Christmas.

1 Like

Hi Florian,

Just curious as to exactly what you did when fixing the issue, as I think I have something similar.
I am also playing with the new UI, but my items are not receiving their status. If I put in my phone battery status for example, then the item state does not show on the page. When I open the same page on my iPhone it works as expected and it shows the correct percentage. All my items are updating fine in HomeKit, but not in the Main UI.
I also created some masonry, only in the widget however, which Is why I found your post.

My “testpage” with only one item:

label: Overview
- component: oh-block
config: {}
    - component: oh-grid-row
      config: {}
          - component: oh-grid-col
            config: {}
                - component: oh-gauge-card
                    item: PeterBattery
                    min: 0
                    max: 100
                    type: circle
                    title: Peter Phone
masonry: [] 

Does this (the masonry part), look like what you got?
Thank you:-)


i think in my issue it was more like

masonry: [

so basicly an additional page break, but i am not sure anymore.
Maybe a look in the JSON Backup helps?

Thanks-I’ll have a look.