Cannot configure Aeon Smart Switch6 entirely in Habmin


I have a Aeon Smart Switch 6 and got all working. Only thing I would like to change in the configuration parameters is to update more frequent the meter reports. I installed Habmin2, but do not have access to the parameters 101 and 111.

Any suggestions ?

How recent is your version of openHAB, the z-wave2 binding, and Habmin? The reason I ask is those parameters are there in mine.

Hi Jim,

Thanks for your reply. I am using:

  • OpenHAB 2.0.0
  • Zwave Binding 2.0.0
  • Habmin 0.1.3

Cannot see this parameters… Strange ?1?
I used Paper UI for discovery, is this may be the problem ?

I think I know why they are not appearing. This is a device that I recently added the rest of the parameter options to, and those changes have not made it through the build process yet. @chris is working on a pile of changes right now that should include the updates for this device when the rest of the changes are ready.

so you configured it directly in the e.g. node2.xml…

You can’t make changes to parameters in the XML file - this won’t be updated in the device…

ok understand. So is there another way I can tell my device to update more frequent ?

If there’s a problem with the database, then it will require an update - there’s no other option I think.

but how come that jim can configure it ?

Jim has an updated test version - I guess the change is included in that version?

so a snapshot of habmin ? or openhab ?

Yes, a snapshot of the zwave binding…

chris, I downloaded eclipse and did a fresh build, but now can’t get habmin running. Do I have to place the jar into the addons folder “openhab2-master\git\openhab-distro\distributions\distribution-resources\src\main\resources\addons” ?

If you’re tying to run HABmin from within the IDE then you need to import the JAR using FILE | IMPORT.

into which folder ?

It doesn’t ask to import into a folder does it?

In the dialogue: General ->Archive File and then I select the Jar File "org.openhab.ui.habmin_2.0.0.SNAPSHOT-0.1.3.jar"
and then I have to specify a folder

I think you need to import it as a plugin and fragment - not as an archive file.

Hey Chris, this is driving me crazy…
Installed IDE and was not able to get HABmin working.

Then switched back to latest snaphot builds from cloudbee… Got all working incl HABmin, but looks like I cannot configure there the configuration parameters 101 and 111.

What am I doing wrong ?