Cannot create alexa routine to control string item defined as ModeController

I’m trying to control a simple string item which is currently not linked to any thing with OH3 MainUI.
Item is set as follows:

and the Alexa metadata is as follows:

Discovery from alexa works fine and I can see the item in my alexa app. I also can control the item through the alexa app but if I try to create an alexa routine to control the item, the item doesn’t show up and I cannot select it to be included in my routine.
BTW, in OH2 with same settings it worked fine.

Anyone is having the same issue?

do other items show up so that they could be used in a routine ?
In an other thread a user reported that items can be switched on/off using the app but they are not visible so that they cannot be selected to be used in routines.

yes they do and they can also be used in routines.

I’ve read these other threads and my understanding is that they had the issue of items not showing up at all, but my item is visible and can be operated from alexa, the only limitation is that I cannot use it in a routine.
I already dropped the item and recreated, also with different names and lables: nothing. It has to be with the ModeController configuration which I’m not getting right.

Hi There, anyone having the same issue? Or, on the contrary, anyone has this working fine?
I’m running OH 3.2M2

Just to be clear, only lights, scenes/activities and Alexa groups can be controlled in Alexa routines via smart home actions. So this is expected.

In order to be able to control other items with Alexa routines, if going the Alexa skill route, you can create proxy items and associated rules modeled as scenes that can be use in these routines.

The other option, as many have done, is to setup rules derived from the Amazon Echo Control binding last voice command channel that would send commands to the relevant items when a specific routine voice command is requested.

Thanks Jeremy. If this is expected behaviour that’s something that has changed recently, as I had this working in OH2 (not sure if even in OH3.1, can’t remember when it stopped working).
I personally think this has changed on amazon side.
Anyway thanks for the explanation, it’s a bit annoying to set up proxy items…


So, I have to apologize on this one. I missed the top menu option “All Devices” in the Alexa routine smart home action menu. I actually don’t use that functionality as I usually prefer using scenes and rely on the OH rules engine.

Anyway, it should be working as you expected it. Have you tried to delete the device and rediscover it? You indicated that you can control the item through the Alexa app. Do you see the same modes you defined on your item?

yep, many times.

yes, same modes.
Previously, the Alexa app showed ModeControllers in the “All Devices” option, but now it doesn’t show them. Not talking about one specific item, I’m not able to get any ModeController item showing up. But on the other hand, all my ModeControllers are manageable via Alexa app.
What I deducted so far is that either Amazon has stopped supporting the control of ModeController via routines (which is weird), or there is something wrong with my configuration, or there is something wrong in how the skill responds to Alexa on discovery call (some new parameter that has to be set up to for Alexa to include the item in “those controllable via routine”).

I digged into Alexa developers documentation but I couldn’t find out anything mentioning new expectations when discovering devices.

So to exclude I’m setting the item configuration wrong, I was asking if anyone in the community is having the same issue I have, i.e. ModeControllers controllable by Alexa but not showing up in the list of devices that can be controlled by a routine.

thx, ciao

So I ran some tests and I am pretty sure the issue is that your server regional settings aren’t setup properly. This mean that the modes you setup are defaulted to English and therefore, there is technically no friendly names available in your language which I assume is Italian.

The odd part is that it will still show in your available manageable devices but it will not in your available smart home routine devices as you noticed, while I would have expected the former to not be displayed as well. You can set language="it" on one of your affected items just to confirm my theory.

Thanks for taking te time to test.
It doesn’t work.
In my server regional settings I had location and time zone pointing to Italy but left language = english (I preferred the MainUI to be in English). So I set it to italian to give it a try, but it didn’t work.
Then I tried setting the language on the item alexa metadata to “it” but nothing changes.
Then I reverted all to English, created a dummy string item and set only the “supported mdoes” in alexa metadata to “Open,Close” in English (didn’t touch anything else), set language to “en” but I still can’t see it showing up in routines.
Operating the item from alexa app was always possible with the many different configurations of the supported modes.
(of course I completely removed the item from alexa every time I changed something to force a new discovery).

this is really weird.

Not sure what else to tell you other than to check the language your Alexa app is setup as.

You could always raise an issue with Amazon through the app stating it was working before. They should provide you the reason for not being available in routines.

1 Like

Magic happened and now it’s working again…