Cannot find/add z wave devices

  • Platform information:
    • Hardware: VM (ESXi 6.5) Intel X5570 2 cores 2 sockets @ 2.93 GHz
    • OS: Server 2016 on ESXi 6.5
    • Java Runtime Environment: Java 1.8.0_171
    • openHAB version: 2.3.0 Release
  • Issue of the topic: Unable to add z wave devices besides z wave controllor
  • Please post configurations (if applicable): z wave controller is aeotec zwave gen 5, I’ve paired a Aecon labs multisensor (DSB05-ZWUS) and 2 GE Toggle Dimmer Switches with the pairing mode for each device. When I go back to my web interface I am unable to find any new devices.

I am completely new to openhab and this is my initial setup, so I might just be trying to do this wrong. I had a smartthings before and all theses devices worked (and then some, side note, does the centralite 4257050-RZHAC work with z-wave? Can’t even get it to pair with the aeotec zwave stick).

The zwave stick does flash blue, yellow, red, not sure if it’s supposed to at this point, it is plugged into a usb 2.0 port and then passed through ESXi 6.5 to a Virtual Server that is running Windows Server 2016.

If any other details are needed let me know.

This is a Zigbee device, and it will work with the Zigbee binding if you have a controller. It’s also listed as supported.

This is normal. It will flash colors while communicating. Have you started a Zwave discovery in Habmin (magnifying glass with plus sign) or PaperUI?

BTW, it is best to do your inclusions through OH so that your routing is correct.

I didn’t even know about HABmin. I have installed it now but don’t see the magnifying glass. Also don’t know how to start zwave discovery in PaperUI.

You are discovering Things, so go to Configuration> Things. You should see the magnifying glass then. Similar in PaperUI.

Still not finding anything. I tried the discovery waited for about 10-15 minutes watching it, then left it go for several hours and checked again.

After that I put the z-wave antenna into exclusion mode and removed the two GE Switches just in case that was why it was not seeing them. Again, waited about 10 minutes before walking away, didn’t find anything.

Just to confirm, did you also set the device into inclusion mode after starting discovery? The inclusion/discovery will end after a minute (configurable in the controller Thing) and the Things should show up in your Inbox and will then need to be added.

Since you are still having issues, you may want to try this again because this could definitely be causing the issue. You could also do a full reset on them too.

You could be having an issue because of running in a VM. What do you see in Habmin when you drill into the controller and how is it configured (you can post screenshots into the forum)?

You may also need to look at some logs to see if the controller is actually functioning by running log:set DEBUG org.openhab.binding.zwave in the Karaf console, but remember to set this back to WARN when done looking at the logs. Check the logs from an OH restart. This post has some details on doing this in real-time. But you can also setup VS Code with the OH Extension to easily get into Karaf and do the logging from there.

This could be a complex issue, so it will be good to get the basics out of the way before drilling in too deep!

I’m not sure how to set the device into inclusion mode in things, At least I don’t see a setting that does it. (unless we are talking time? In which case i set i to 3600 seconds and wake up every hour, which if I understand it, means it should be searching constantly).

Is this what you are looking for:

I’ve been thinking I might switch to a standalone machine to see if that’s the issue, but I wanted to make sure I’m even doing this all correctly. Everything I see online seems to indicate adding a zwave device once i have the antenna added should be as easy as adding everything else I’ve done (hue, ip devices, etc).

I was meaning the device itself. I don’t have any GE dimmers, but the manuals all seem to say to press and release the top or bottom of the switch. To set OH in discovery, use the magnifying glass in Habmin or Search for Things (or big blue + button) in PaperUI. Both the controller and then the device need to be put into inclusion mode. The Inclusion Mode Timeout is how long the controller will be put into inclusion mode. I think default is 60s.

I don’t think this will be necessary. Let’s just make sure you have the process down before digging deeper.

Had to travel for work the last couple weeks then family vacation to the inlaws. I have ordered a new antenna (Laniear HUSBZB-1 since it does both z-wave and zigbee - and I have 2 more GE Switches. Once I get the new antenna I will try again and see if I just had a lemon z-wave antenna.

1 Like