Cannot get Aeotec Key Fob Scene numbers or battery level to appear

  • Platform information:
    • Hardware: Raspberry Pi 3
    • OS: OpenHabian
    • Java Runtime Environment: ?
    • openHAB version: 2

Hi all, I’ve decided to try OpenHab again after using Home Assistant for a year. It seems like OpenHab has a come a long way since I last looked, however I’m struggling to get my Aeotec Key Fob working properly.

It was always a pain to bind the fobs with Home Assistant in the first place. My old process was:

  • Press the bottom right button, or the learn button on the back
  • Press add node on Hass
  • When it’s paired go to set parameter and set param 250 to scene
  • If it reverts to Group then press and hold learn on the back of the fob for 3 seconds - this will awake it for 30 seconds
  • Repeat setting param 250 to scene until it sticks.
  • Restart the server
  • After restarting Hass will show the name Aeotec KeyFob Gen 5 etc
  • Rename the node to whatever
  • Restart Hass
  • Done.

I can’t for the life of me get this working with OpenHab though. I’ve tried completely resetting my Aeotec Z Stick and Key Fobs to defaults and then following this procedure:

  • Disconnect the Z Stick from the Pi and press the learn button
  • Press the bottom right button to learn
  • Green LED blinks fast and goes solid to indicate it’s paired
  • Plug the Z Stick back into the Pi
  • Press the mode and learn button on the back of the fob to put it in Scene Mode
  • Restart OpenHab (sudo reboot - not sure why this need to reboot every time to find new devices)
  • Open PaperUI
  • Add the Thing
  • Add the scene number and batter level as channels
  • Go to the Control area and look at the values
  • They are always “-” regardless of what button I press and the battery level never gets reported.

First post and question on this community, so I hope it’s got everything I was supposed to put.

Many thanks in advance.

What I’ve done

  1. plug the z-wave stick to the pi, it is not needed to unplug it for include
  2. start habmin
  3. go to things and select z-wave stick
  4. select z-wave binding on the left upper magnifying glass icon with the plus in it, this start z-wave inclusion mode
  5. click all 4 buttons of the key fob for some sec.
  6. prss left upper key fob keys
  7. this should include the key fob to the stick.
  8. manually wake up the key fob for some times to fully recognize it by OH


Thanks for the reply. It sounds like we might not have the same version of the Z Stick? Mine is the gen 5 one. Pressing 4 buttons doesn’t do anything special according to the docs.

I’ve tried once again resetting both to complete defaults. I’ve included it through OpenHab this time, but now it’s not picking up it’s a key fob. It’s just sat as “Z Wave Node 3”. I’ve tried waking it by holding the bottom right button for 3 seconds to force a wake up, and putting it in USE mode and spamming all the buttons.

Right, I managed it eventually. Seems to have been mostly blind luck.

  • Reset both controller and key fob to factory defaults
  • Deleted all bindings and channels in OpenHab
  • Plugged in and reconfigured Z Stick within OpenHab
  • Rebooted OpenHab
  • Went to HabAdmin to the Z Stick
  • Clicked the search icon in the top left as per HomeAutomation’s instructions above
  • Pressed and held the learn button on the Key Fob
  • Added the “Thing” once it was detected
  • Manually set the device to Scene mode and set wakeup time to 30 seconds
  • Put the device into Scene mode by pressing the mode and learn buttons simultaneously
  • Pressed and held the learn button on the back with a pin for 3 seconds to force a wake up
  • Repeat last step about 5 times
  • Add channel for battery level and scene
  • Repeat force wake up again
  • Battery level appeared
  • Hit the scene keys - they worked!

EDIT: Didn’t actually work for the 2nd fob I have. It’s just sat as an unknown device an hour later, despite constant wake ups. Oh well… will keep trying.

Final solution:

  • Reset everything to defaults
  • Remove all channels and things from OpenHab
  • Reboot OpenHab
  • Pair using the Z Stick to the key fobs
  • Plug in the Z Stick
  • Reboot OpenHab again as it doesn’t see the port number when it’s plugged in for the first time… bug?
  • After rebooting configure the port and save the thing from HabAdmin
  • Reboot again
  • Search for things from HabAdmin and the two new devices appear immediately as they’re already paired
  • (Using the pairing from the Z Stick it instead OpenHab, it gave me the Wake up configuration options)
  • Set the wakeup time to 30 seconds and notify node 1
  • Spammed the learn button (3 second hold) a few times - didn’t do anything, but occasionally looked like it was exchanging data
  • Rebooted OpenHab again
  • Spammed the learn button again a few times - again didn’t pick up any information
  • Went to bed
  • Woke up 8 hours later and it has all the information.