Cannot get myopenhab secret

I have been playing around with openHAB for the last two days and I was trying to create a myopenhab account. I downloaded the required file and copied it into the addons folder, made the changes to my openhab.cfg file and re-started openHAB. The secret file just does not appear in the webapps/static folder. I am running openHAB on a MacBookPro OSx 10.10.

Did you install openHAB manually or using the apt-get method?

The first time I did it I did it manually, and several things didn’t work properly. One of which was that the secret didn’t appear. Which sounds like the same problem you’re having.

Maybe save everything you’ve created somewhere safe and install using the apt-get method. I think it sets the right permissions etc when it installs, so solves a few niggles like these.

If by manually you mean downloading the files and letting OSx extract them, and then copying them to the Applications directory, then yes, this is how I installed openHAB.

I created a secret file and typed in my own secret and that enabled me to register for myopenhab. I was really just trying to get the openHAB app to work on iOS, but I kept getting an error for “no remote URL entered”. This let me register, but the iOS app still is not seeing my server. I will give it a go by apt-get installing it (after I copy my items, config and sitemap to a safe location)!

So how did you install openHAB with apt-get in OS x? I’ve looked into installing fink for apt-get to work, but that does not look suitable, is it possible to install openHAB through homebrew?

Since this install is just so I can set up the configs until I get my raspberry pi 2, I may just install on a Linux Mint vm I have hanging around.

I’ve not done it myself, but OS X is just a flavour of Linux isn’t it?

Open a shell (under Applications/Utilities) and follow the install instructions. As I say, I’ve not tried it, but I assume it’ll work???

Or yeah, wait for the Raspberry Pi, dead easy (!) on there if you ssh into it from the Mac.

Like you say though, as long as the secret and UUID match in both locations, it will connect.

ok, so OS X is not so much Linux, but more UNIX… Little bit different, but not much…

I installed openHAB on a Linux Mint 13 (Maya) virtual box that I had kicking around and I added the jar file into the addons folder and I got my “secret” file created.

Which created a new issue. I updated my settings in my account (new UUID and secret) put my info into the settings on the iOS app and I get nothing on my iPhone. I sent a message from my account on the website and received it on my phone, but still nothing shows up with the controls from my sitemap… go figure… I keep getting “request failed: internal server error 500”