Cannot reach UI with OPENHABIANPI addressing, only direct IP address

I dont’t understand why I cannot connect my RPI directly by name. However direct IP adressing is working and adding .local after PI name is working too.
http://openhabianpi:8080/start/index – Not working
http://openhabianpi.local:8080/start/index – working
http://192.168.xx.xx:8080/start/index – working

It’s not a big issue, but more annoying for day to day task. Example, when I reach the UI selection page, I always have to modify the address manually to reach Grafana because the link provide is http://openhabianpi:3000/ and not reachable.

Is someone could explain me why I cannot reach my device normally like explained in documentation?

This is not an OH issue but a configuration issue with your DHCP, which is often in your router

Thanks @luckymallari, I will check to get information about my router configuration.

That’s not a DHCP Problem, thats a DNS problem. You Client (PC) does not resolve the dns name.

In Case of you router doesn’t support this, you can do it manually

“IP from OH” -> “dns name”

example: openhabianpi

It is a DHCP problem. You do NOT need to manually add to etc/hosts if your DHCP is correctly leasing the pi with IP, and resolving properly. 99.99% of homes that have routers, usually the routers are the DHCP server and DNS gateways.

If yours is the case, then I guess I would have to add 50+ resolutions on my hosts file :wink:

@luckymallari, @openhaber, I agree to both of you.

I will first fix my issue by overriding my router by adding a local DNS on my PC. Currently, I’m working with the router provided by my internet provider. It’s a basic Sagemcom modem/router with a proprietary firmwer from Bell (the internet provider). Not much option to manage.

I will disable that router and use a D-Link DIR 860L. I know it’s probably not the best router on the market, but I will give it a try. There is much more option in there.

Thanks again to both of you.