Cannot upgrade my configuration Snapshot to newer snapshot

So I’m running 2.0.0-SNAPSHOT Build #743
Now, I want to upgrade to latest snapshot which is 2.0.1 build #8
So I followed guide in manual and when I run the openhab, It seems to be running the old version, as service. So I logged in with karaf and it said 2.0.0-SNAPSHOT build #743, I did another reinstall this time without copying my configuration over itself and it worked ok, I see version 2.1 in karaf.
I did try deleting the tmp and cache folders from userdata folder but it did not work.
I’m sorry if somebody asked this already.

The docs seem to link to an old repo. The snapshot repo has moved, see here:

Sorry! My fault, if you’re following the manual installation then you need to replace that wget line with the following download link:

I will fix the docs.

This link, as the one in the manuals, gives me 404. So I did download the 2.1.0 snapshot, I’ve put 2.0.1 instead of 2.1.0 in my original post, sorry for that. Anyway, is this supposed to work this upgrade procedure to the 2.1.0 snapshot?

Yes, sorry. I did the same mistake here as well as on the docs… On a roll of error here. Edited the above link