Can't add channel to IHC / ELKO Binding on OH 3.0.0

Hi All

Having installed and configured my IHC binding and having connection to my controller with succes through the IHC Thing I can’t add channels to it.
I can enable the auto channels with no problems but I can not add new ones
Usually when clicking the add button it stays in “loading” for at least 8 hours (The longest I have tried)
But I have tried one time when I had created the IHC Thing without enabling the auto channels to get this error message when trying to add a channel:
Url: /settings/things/ihc:controller:IHCControllerBryggers/channels/new
Path: /settings/things/ihc:controller:IHCControllerBryggers/channels/new
Route: (.*)
When trying to add through the code page it looses the connection to the controller and even if I undo the editing it will not reconnect without me deleting the IHC thing and adding it again from the start.

I can make the auto added channels work fine.

This is on a RaspBerry Pi with Openhabian installation

Have any had any similar experiences and or solutions to it.

Please say if I can provide any added information if needed
I can say that the logs doesn’t give more information apart from them logging when the Thing looses its connection to the controller.

Thanks in advance


I am having the same issue and follow this one to catch any options for fixing.

I have crated this GitHub bug to fix it as it does not seem to be wrong use but an error:

I hope for the best on this issue :slightly_smiling_face:

It seems that this have been fixed now and it is targeted for the 3.1 milestone.
Thanks a lot everybody who contributed.
I am looking forward to the release of it.