Can't Add Neo Coolcam Door/Window Sensor (Z-Wave)

hi community

i’ve a big problem with the neo coolcam door/window sensor. when i’ll include this sensor, the device will be shown as unknown z-wave node 43 in the inbox.

i use the follow z-wave snapshot version:
2.2.3 download-date: 08-01-2017

in habmin ui, there is no manufactor and type shown.

The logfile shows this after adding …

2018-01-08 22:18:32.076 [DEBUG] [org.openhab.binding.zwave           ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.core.status.ConfigStatusProvider}={, service.bundleid=239, service.scope=singleton} - org.openhab.binding.zwave
2018-01-08 22:18:32.080 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler.
2018-01-08 22:18:32.091 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 43: MANUFACTURER not set
2018-01-08 22:18:32.093 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 43: Controller status changed to ONLINE.
2018-01-08 22:18:32.094 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 43: Controller is ONLINE. Starting device initialisation.
2018-01-08 22:18:32.099 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 43: Updating node properties.
2018-01-08 22:18:32.104 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 43: Updating node properties. MAN=2147483647
2018-01-08 22:18:32.106 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 43: Initialising Thing Node...
2018-01-08 22:18:32.107 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 43: Polling intialised at 1800 seconds - start in 1800000 milliseconds.
2018-01-08 22:18:33.126 [DEBUG] [wave.internal.protocol.SerialMessage] - Assembled message buffer = 01 03 00 16 EA 

I’ve try to add and wake-up the device (over button on device) many times, but no change to receive manufactur and typ.

does someone knows, where can be the problem?
does anyone have experience with this device?

1 Like


you have to push the buttion 3-times, not only 1-time. And you have to do it often, believe me. I had the same problem.



I have 9 of those sensors and also the Z-stick. Initally I also had trouble to get them fully included.
I put the stick in inclusion mode, pushed the button 3 times on the sensor. Put the stick back into the PC and ended up with unknown devices.
No matter how often I would wake them up, they would still stay unknown.

Now here was my solution:

BEFORE mounting them to the window, do the inclusion with the stick as you would normally do.
Then put the stick back into the PC.
Take the sensor real close to the stick, which is now connected to the PC.
Push the sensor button 3 times.
You might have to repeat the last step 2 or 3 times.

Now they work like a charm for me. They are really good value for the money.

1 Like

Do any of you have problems with these sensors not updating openhab with its battery status?
or errors about waiting for initialisation?

How did you solve them?

Same here.
Devices included successfully, report open/close without any problems - but battery status is never updated.
Tried to use different methods to obtain bat level (battery-level and command=battery) but to no avail:

Number attic_window_1_bat "Attic Window 1 battery" <battery> (gWindows,gAttic,gBattery) {channel="zwave:device:52508370:node7:battery-level"}
//Number attic_window_1_bat "Attic Window 1 battery" <battery> (gWindows,gAttic,gBattery) {zwave="7:command=battery" }
//Number attic_window_2_bat "Attic Window 2 battery" <battery> (gWindows,gAttic,gBattery) {channel="zwave:device:52508370:node8:battery-level"}
Number attic_window_2_bat "Attic Window 2 battery" <battery> (gWindows,gAttic,gBattery) {zwave="8:command=battery" }

Openhab 2.4 on OrangePi, default zwave binding.
On the same network I have a few Danfoss LC13Z TRVs, those report the battery just fine.
I haven’t changed any associations on the Neo Coolcam sensors but the description says it should send BATTERY_REPORT on the group 1 as well as NOTIFICATION_REPORT and SENSOR_BINARY_REPORT.

I have the same issue.
Have you found a solution?

Hi all
I have the same issue with battery in a new NAS-DS01Z Door/Window Sensor
I’ve tried several things, but I’m not able to get the battery level
Does anyone a way to fix it?

Thanks in advance