Can't Add ZFM-80 Switch Module

I have two ZFM-80 dry-contact switch modules that I am migrating from my old Wink hub to my new OpenHAB setup on Raspberry Pi. I was able to exclude one from Wink and then include it without any difficulty. The other never shows up on OpenHAB when I try to include it. The only difference (I know of) is that when I was first trying to transfer it, I accidentally told Wink to “remove failed node” instead of remove in order to exclude it. However, I’ve been able to include and exclude it from Wink multiple times. I’ve tried to exclude it from both the Wink Hub and OpenHAB.

Any thoughts on what to try?


What version of openHAB are you running?

Try excluding the device first. If it was not properly excluded from the Wink hub, it will not join another network, Any controller can exclude a device though.

Thank you! I’ve recently installed 2.5.4 Release. I’ve tried to exclude from both the Wink Hub (which claims exclusion success), and from OpenHAB (both PaperUI and HABmin). Of course, my new SiLabs ZWave controller has no relationship with with the module, and gives no feedback on exclusion. However, after exclusion on the Wink Hub, I can still add it back to the Wink Hub.

Is there any kind of full factory reset for the Remotec ZFM-80?

Looking at the manual in our database entry they claim excluding it resets it. I have not heard of that before.

For most devices, excluding the device can be done from any controller - even if it is not included into that controllers network. Once excluded, the device should be in a reset state. There are some new/complex devices where this is not the case, but for most devices, once it’s excluded it’s the same as a reset.

1 Like

I have found some of my cheap Chinese devices need to be factory reset before including into a different network. Excluding alone was not sufficient.

Strange. Most devices should use the standard firmware from Silabs so should work the same.

I even had a new Neo Coolcam device that would not include properly the first time until factory reset.