Cant adjust sonos volume when using Say command (on Connect:amp - works on Play1)

I’m running OpenHabian 2.4 on a brand new Raspberry Pi 3B+.

I have a sonos amp that I am trying to play the say command to. I have it configured as the audio sink for the system. I am doing TTS through googles API.

When I issue something like

say (“This is coming out of the sonos”)

It works, but it is very faint. You can hear it if there is nothing else going on in the room, that quiet. I cannot get it to go louder.

When I do this:

rule “TestSwitch run”
Item Infrastructure_TestSwitch changed
val float vol = getMasterVolume()
logInfo(“test”,"volume " + vol.toString)

setMasterVolume(new PercentType(75))

val float vol2 = getMasterVolume()
logInfo("test","volume " + vol2.toString)

say("test, test, test", new PercentType(75))

logInfo("test","test routine triggered")


I get log entries that say the volume is .2 before and after the setMasterVolume. The say with the 75 I added and that also just plays at the same volume.

I’m not getting any errors, it’s just not accepting my setting for the volume.

Any ideas would be really helpful!

I’ve read all the other posts on Sonos problems, none have helped!


So… I had a rare moment of clarity and I went and grabbed a Sonos Play 1 and set that up for my audio sink. Immediately the same code started working fine. When it ran I could see the volume settings change, the voice got louder, the say command worked.

So I have them all configured in my items the same way … is it possible it is something with how the AMP works? What can I do to help troubleshoot this?