Can't change the heating of thermostats in openHAB 3

Tags: #<Tag:0x00007f432cee3358> #<Tag:0x00007f432cee3268>

Hi,

I’ve just installed a fresh openHAB 3 system:

  • Platform information:
    • Hardware: Turris Omnia 2019, ARMv7, 2GB RAM, USB-Z-Wave-stick
    • OS: Ubuntu 20.04 in a LXC-container on TurrisOS 5.1.4
    • Java Runtime Environment: java-1.11.0-openjdk-armhf
    • openHAB version: 3.0

I followed the documentation and created everything in the user interface. It seems everything looks and works fine except for my two thermostats (which are from two different vendors). I cannot change the desired temperature (heating) in the user interface - because there is no input field. Only the manually set values are displayed (set on the thermostat). Here is a screenshot of one of them:

It is a Spirit-Z thermostat. The other one is a Popp Thermostatic Radiator Valve. The Popp thermostat worked in the PaperUI of openHAB 2 with the automatic binding.

Which configuration setting leads to an UI element (input field) for changing the values?

Thanks,

Heiko

You need to manually install the snapshot version of the binding. There was a problem fixed in the binding database.

I do not think the update script works with OH3.

1 Like

Could you please send me a link for downloading the snapshot version and a link to a document describing the installation process?

The README of this script describes the process. The script was for OH2 though.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

Here is the latest 3.1.0 snapshot.

1 Like

I have the Spirit-Z as well and I am on OH3 stable, too. In the configuration pages I cannot set the temperatures as well, but it works just fine in a sitemap with the setpoint element.

@Bruce_Osborne: The binding issue was limited to the Spirit-Z as far as I remember, the Popp thermostat should not have been affected by that?

1 Like

Eurotronic Spirit, I believe

In OH2 I had problems to discover the Spirit-Z (look here), but no problems with the Popp thermostat.
Now in OH3 both are fully discovered, but for both I can’t change the temperature in the configuration pages. I’ve not tried it in a sitemap so far.
Do you think, that the binding update - which Bruce suggested - didn’t help?

Hey,

I’m running OH 3.0 and all of my Eurotronic Spirit thermostats running fine.
To change the temperature in item/model-view I changed “Default List Item Widget” and “default Standalone Widget” under “Add Metadata” to Slider-widgets with min:8, max:28, step:0.5, Display Label, Display State, Scale steps: 4, Scale sub steps: 1 and Unit °C

1 Like

Thanks, that is the solution. It works for both thermostats.

Where is this nice feature documented? I can’t remember tor read something about it.

The Spirit-Z has also a second, similar channel (thermostat_setpoint_heating_econ instead of thermostat_setpoint_heating). Do you know the difference between them?

Did you look at the manual> That is usually where we get the information from.

1 Like

is used for reduced temperatures e.g. as a night setting. In essence you can define two setpoints, one for normal operation (set “thermostat_mode” to 1) or for a reduced temperature (set “thermostat_mode” to 11).
Usually you define the value for channel “thermostat_setpoint_heating” with a higher value as “thermostat_setpoint_heating_econ” (which is the setpoint for a reduced temperature).

1 Like

Hi Bruce,

yes, I read the manual of the device, but there was no information about the Z-Wave channels. Maybe the manuals are different in the USA and in Germany.

Thanks for your explanations and hints.

Hi Stefan,

thanks for your help.

Look here

At the bottom of the page is the manual used for the binding entry.

1 Like

I found a documentation of the feature (changing the item/model-view) in the following post https://community.openhab.org/t/wiki-building-pages-in-the-oh3-ui-documentation-draft-2-3/104392.