Can't connect local host anymore


I used to be able to connect with my laptop to OpenHab on my raspberry pi using “raspberrypi.local:8080/” but since I’ve open an account with myOpenHab and change the security settings in openhab.cfg I can’t anymore.

I’m able with my phone if I don’t use the wifi but when using wifi it won’t work, on my Mac it ask me for a username and password, I used the myOpenHab password but to no sucess.

The problem I think is here “security:netmask” I’ve entered different settings but it doesn’t work.

Any clue?

You have to set the netmask to match your internal network.

Find out your mac’s ip adress:
Go to “system preferences” “network”, your internal ip is something like:

Disregard the last two (or three) digits and keep the other digits, your netmask is:

Another example: internal ip =, then the netmask is

I was finaly able to make it work, I took the Raspberry IP address and I added at the en /24 and it worked!

Thansk for the help.

I’m pretty sure that won’t work on the long run if you try to connect with other devices.
You need to have .0/24 at the end.
For more explanation see
and maybe use the calculator here:
Type in your Pi’s IP adress and calculate, You will see the string you have to put in your config after

Ho…I’ll check that, thanks for the cue!