Cant connect to MQTT Embedded Broker

Ive setup the MQTT Embedded Broker but cant connect to it with MQQTLens.
Tried from that machine, and from other machines in the network - no luck.

I’ve changed the port to 555 just to make sure - no luck.

As You can see it has opened a port, but to localhost, not What am i missing?

Thank You!

On which system does OH run and which versions?

What embedded broker? I only found this infos

“It does not provide MQTT broker functionality …”

This one
But I think it is quite experimental and I haven’t seen any docs for it yet.

@Milika_Delic, I would stick with mosquitto in the mean time

Ahh, another app on the home server them, plus mosquito is a pain to install on win32 :slight_smile:

Thank You!

Use linux then :smiley:

I have tried to get the Embedded MQTT Broker binding to work this weekend but the mqtt broker only accepts connection from the localhost. Looking at the code I found that he accepts only connection from

properties.put(BrokerConstants.HOST_PROPERTY_NAME, "");

The code must be updated with "" to accept remote connections!

because I was not able to compile the jar file, I managed to patch it after I could connect with “mosquitto_sub” from different computer. Does anybody knows where I can post an issue?

It was introduced in 2.3.0 PaperUI>Misc so it’s been around a while now. It’s a shame that there is no documentation. I can get MQTT Fx to connect to it but can’t get it to function so gave up.

How can I patch it?
And will the patch be “upgrade proof”?

Thanks. I plan on moving from external broker to internal one to have “all pieces” together.

As far as I could check, it already should be in the new snapshots.

Edit : Just checked with my running openHAB 2.4 Milestone 3 system and can confirm tha I could connect to the embedded broker from another machine.