Cant connect to openhabianpi:8080 on some computers


I have a RPi 3 running openhabian, but i can access ipaddress:8080 only from 1 pc. The other pc’s on the network are unable to reach this page:

Neither from the browser nor from putty. The PC that can access can do it from the browser as well as from the putty.

Please, help!

Thank you!


What version of OH are you running?

What browser are you using?

What does the page say when you try to access OH UI?

Please take a moment to read this topic.

I am running OpenHab 2.
Google chrome, chronium and edge.
“This site cant be reached”

I tried ping on the computer with the RPi IP but it does not ping even though they are connected to the same network (192.168.0.XXX).

I guess it is an issue on the network configuration but i have no idea what it is.

Thank you!

When pinging the server use only the IP address without the port number. You may have tried this way if so then I agree it looks like an issue with your network.

This does sound like some sort of network configuration problem and we are going to be limited in how much we can help you on this forum. We are OH experts, not networking experts.

If you can’t ping it and can’t ssh to it then the problem is going to be in your router/gateway, firewall, or on the RPi’s configuration.

So what is different about the one PC that can reach the RPi and your other machines? Are they using different subnet masks? Are any of them configured with static IP or are they all using DHCP?

These are not questions I want you to post the answers to here because I’m not going to be able to help even with the answers. But these are the sorts of questions you need to be asking yourself and based on what you find out searching google or perhaps posting to an RPi forum to figure out what the problem is.

It is very odd fore sure.