Can't create things openhab 3.0

  • Platform information:
    • Hardware: I3-8100, 32GB RAM
    • OS: Ubuntu 20.04.1 LTS virtual machine on Proxmox 6.2.4 (4x common KVM processor 8GB ram)
    • Java Runtime Environment: openjdk version “” 2020-11-04
    • openHAB version:

version: 3.0.0
buildString: Release Build
locale: nl_NL
configFolder: /etc/openhab
userdataFolder: /var/lib/openhab
logFolder: /var/log/openhab
javaVendor: Ubuntu
osName: Linux
osVersion: 5.4.0-58-generic
osArchitecture: amd64
availableProcessors: 4
freeMemory: 120827568
totalMemory: 263192576

  • Issue of the topic: Can’t add things


I’ve installed openhab 3.0 on my Virtual ubuntu machine.
It running and can login with the IP:PORT on my other computers.
But i cant add bridge things.

For example, i want to add my evohome gateway.

So i’ve installed the add-on, and go to things.
Click the blue + button and select the evohome binding.
Then i fill in the username/password and click on the blue “create thing” button.

After that its going back to the things page, but there are no thing in the list.

Also tried it with other things, like buienradar, dmx, onewire.
It’s all the same.

What am i doing wrong?

Hi Niels,

Welcome to the forum.

I’m not using openHAB v3 myself yet so I have quickly spun up an openHAB v3 docker container.

Here are the steps that I took to install and configure the Buienradar binding. I guess you somewhere missed a step.

Select ‘Bindings’ from the ‘Add-ons’ section.

Click on the blue circular button in the lower right corner.

Enter Buienradar in the search box. This will show the Buienradar Binding. Click on it.

Press the ‘Install’ button from the popup at the bottom of the page.

Select ‘Things’ in the left side menu.

Select the ‘Buienradar Binding’ in the middle of the page.

Select the ‘Rain Forecast’ in the middle of the page.

Optionally give it a Unique ID and update the label text.

Click on the ‘Johan Cruijff Arena Rain Forecast’ in the middle of the page.

Select the ‘Channels’ tab at the top of the page and click on ‘Current Rainfall’.

Press ‘Add Link to item…’.

Select ‘Create a new Item’ and press the ‘Link’ button at the bottom of the page.

Click on ‘Save (Ctrl-S)’ at the top left of the page. Next select ‘Pages’ in the left side menu.

Select the ‘Overview’ layout in the middle of the page.

Click on ‘Add Block’ in the middle of the page.

Click the ‘Add Cells+’ button.

Click on the newly added empty cell.

Select ‘Label Cell’ (I have not tried them all to see how they differ but this one seems to work :slight_smile: ).

Click on the little black button above the new cell.

Select ‘Configure Cell’ from the popup menu.

Select ‘Item’ below the ‘Label’ section.

From the popup window select the item you’d like to display (here the Johan Cruijff Arena Current Rainfall…’ item).

Click ‘Done’ in the top left of the popup window.

Click on ‘Save (Ctrl-S)’ at the top left of the page. Next click on the openHAB logo.

At first the cell may display ‘NULL’. This is because the Buienradar did not yet request the rain forecast information from Buienradar.

After a while it will automatically update and you’ll see the amount of rain that falls per hour.

I hope this helps.

Thanks for your reply.
After a new installation of Zulu 11 and openhab i did succeed to create a few things.
The evohome and the artnet bridge are working fine. But the buienradar add-on still doesnt work.

Clicking on the blue + button
Clicking on buienradar
Clicking on rain forecast

Added a random location and changed the unique ID and location, then clicked on Create Thing
(Picture) (Could only download one screenshot because I’m a new user)
Automatically returned to the things page, and the buienradar thing is not here.

Have also tried it with the onewire and modbuss add-on and those also didnt work.

Tried to make a modbus connection with my WAGO 750-881 plc. With a special program that acts like a modbus master i could make a connection.

Also with the esara Config tool i can make a connetion with the onewire device.

Did a restart and a clear cache command and now it works!:smiley: