Can't display images anymore?

Running OH3 Snapshot 2200

Trying to show an image located in the html folder.

Code in .sitemap file:

Image url=http://MyServer:8080/static/meteogramm.png

Tried in on a OH3-MainUI created sitemap as well using an image widget (same URL http://MyServer:8080/static/meteogramm.png)
Both not showing the image. Nothing shown in the logs.
Displaying the image directly using the above stated URL is working.

It worked 'til yesterday. The only changes I did were:

  • deselecting Allow Basic Authentication. Setting it back didn’t help (Including restarts)
  • updating to Snapshot #2200

It has to be something really stupid, but I can’t find it.

I can’t say why it doesn’t work now but one thing you can try is to use a relative path. That ends up working better when accessing OH remotely too.


That’s how I reference all the local static images that I use in my pages so far.

Thanks for the input.
Image url="/static/meteogramm.png"
I get the (empty) none.png "displayed.
Image url="http://MyServer:8080/static/meteogramm.png"
the sitemap tries to dispay http://MyServer:8080/proxy?sitemap=Haus.sitemap&widgetId=0700&t=1613155145032. That sounds correct (according the code), but nothing is displayed.
When trying this URL directly I get a:

Problem accessing /proxy. Reason:
Sitemap 'Haus.sitemap' could not be found!

The Haus.sitemap however does show all other data and subpages.

I’m pulling my hairs out, although that is probably good, since all the hairdressers are closed due to …

There has been some issues on github where if you use a real sitemap file VS a sitemap stored in the database you get different results. Suggest you do a test to see if that is a factor.

Thanks for the input, however I have already tried to show the image in a widget of the UI created sitemap (see OP). That doesn’t work either!
I did setup my testing environment and as expected there both (sitemap from file and created by UI) do show the image. That is true for an image of the local host as well as when pointing to the production system host.
Using the picture url like:
is working on the TestServer as well (doesn’t work for the ProductionServer).
I tried to mimic the changes done to the ProductionServer (update to latest snapshot, select and deselect Allow Basic Authentication ) however I could not get the same faulty behaviour again.
I’m short prior updating the ProductionSystem again. The last resort would be a complete new setup.

Updating to #2206 solved the problem!

The needed syntax to show an image stored in openHAB-conf /html is:

Image url="http://MyServer:8080/static/meteogramm.png"

Without the part http://MyServer:8080 nothing is didsplayed!