Can't get IDE running properly

After some long break from openHAB, I wanted to come back to it and I reinstalled IDE.
Unfortunately, there is no way I can get it running, so please help me.
I run Ubuntu 18.04 and installed Photon release, with OH core and binding development options.
Already tried clean install, removal of .p2 and other directories. No help. The issue with building is always the same, however the number of errors were different for different attempts.
Thank you!

The openhab documentation was updated recently for how to get setup for binding development and it clearly states to not select core and binding at the same time or it will fail.
I had huge issues the last few days reinstalling and it was the setup tasks grey out the installation of eclipse of u tick the box to show all setup tasks. This is on windows 10 so it may not apply to you. The ide is in turmoil at the moment with removing the esh namespace. I have it working again but it took some hot wiring of eclipse to get it going because of the installing of the exe was not being done.

That is a good hint. I did not read it, indeed it states about two different build systems. Thank you.
Now everything compiles ok, but running the openHAB_runtime configuration gives the following problems during validation. Anyway if I continue, the systems starts, but there are no UIs available. How can I get paperUI included? Isn’t it part of the core? Thanks a lot.

There’s an issue for this:

1 Like

The problem with validation is now gone.
I would appreciate your help wrt getting paper UI showing up under IDE. I have not tracked actively openHAB for the past months and there may be something obvious that I am missing. Please advise.

Good direction, thanks a lot.
With changes from PR I can use paper UI now.
Thanks a lot again.