Can't get Items into openhab cloud

Hello!

I know that there are many posts to that problem, but I did not find a post that corresponds to the symptoms I see in my installation.

I have installed and configured the “openhab cloud” io service in openhab 2.4.0-1 and in the myopenhab website openhab connection is “Online”/green.

I have connected my iphone as a device in myopenhab, so that I can control my devices with the openhab app on my iphone via myopenhab (which i have added as a remote URL in the app settings).

So I guess, that the connection between the openhab installation and myopenhab is working fine.

When I now open paperUI and add an item, i can see in log viewer that the cloud service disconnects and reconnects. When I furthermore post updates to the item (as well by script as physically by opening and closing the door that corresponds to the item) these item state changes are logged as well, but the item does not appear in myopenhab.

There are no entries in eventlog or notifications in myopenhab.

the only error messages from the service in the openhab log viewer are the following, but I dont know if they are relevant:

2019-08-15 10:19:48.346 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 14962966 failed: null
2019-08-15 10:19:48.354 [WARN ] [io.openhabcloud.internal.CloudClient] - Response Failure: null

I dont know what to do now. I restarted openhab several times and even tried to expose items by creating a config file openhabcloud.cfg. Nothing happens…

Please help!!

Regards,
Jürgen.

Do you have a site map?

Are you opening https://myopenhab.org/paperui or are you opening your local path to PaperUI?

What you you mean by “appear in myopenhab.org”? It won’t appear in myopenhab.org.

  1. Only Items that are to be shared with IFTTT should be exposed to myopenhab.org.
  2. To expose an Item to myopenhab.org you need to configure it in the Cloud Connector add-ons configuration.
  3. The only Items that will appear under Items in myopenhab.org are those that are configured to be exposed (see 2.) and have changed state. Item events will not appear in myopenhab.og’s events log unless they have been configured to be exposed (see 2).
  4. 1., 2., and 3. are irrelevant right now because the Item exposure to IFTTT is turned off on myopenhab.org right now because it is causing a huge load on the myopenhab.org servers and causing problems, a solution is in work.

If you can access PaperUI or BasicUI through a myopenhab.org address you are done. It works.

If you need to expose Items to IFTTT, you need to wait until that feature is turned back on.

If you do not use IFTTT, please please please do not expose your Items in the cloud connector config. It just causes needless load on the myopenhab.org servers.

1 Like

Thank you very much for your reply!!

I can access my local PaperUI through myopenhab.org-URL so as you wrote, everythings seem to be done with my configuration.

In fact I want to use IFTTT for dealing with Tuya/SmartLife devices because of the lack of a direct integration in openhab. For this I just want to expose 2 (max 3) Items to openhab cloud…
It seems as if I have to wait for the feature being turned on again…

The better way for me would be a direct integration of Smart Life devices in openhab. Do you have a suggestion, which way would be the best for this? All the articles I found so far are a little bit irritating to me and seem to habe a lot of pitfalls…

(Will there be an announcement somewhere if the item-exposure-feature will be working again?)

Regards,
Jürgen.

IFTT and, I believe adding new items was turned off due to excessive load crashing the cloud service. @digitaldan has the details.

I suspect there will be an announcement.

Thanks to everybody for your help. I found a workaround until the openhab cloud feature is available again.

I integrated “smart life” in my alexa account, defined an alexa routine that controls my tuya device and now I am able to control the device via the Amazon Echo Control Binding by starting routines…

… but I am looking forward to another solution :slight_smile:

Regards, Jürgen.