Cant get KNX Binding to work properly

I have been trying to get the openHAB2 KNX binding to work, but cant manage to make it work.
I have set up the bridge correctly and it displays it as online. I created a KNX device thing, without defining any address. Then I created a chanel with the group address 9.0.1 which should switch on the kitchen light. This chanel is linked to a item switch. It shows up as online, but if I try to switch it in the PaperUI it wont turn it on. Im using Windows 10, along with openHAB 2.5.3. The interface from the KNX bridge to the app is called EibPort. On there everything works flawlessly.
I hope that someone that has a bit more experience with this can help me out.

Best Regards

Welcome to openHab, Philip !
It would be easier if you could post more details.
Did you create it in the UI or did you use text configuration? How does the thing look like in your text config?
Btw: A title should reflect your topic. Simply “knx binding is not working” sounds as if e.g. there is something wrong with the binding in general.
Please check out “How to ask a good question”.

Kind Regards

Okay, thank you very much.
I have configured it using the UI. I have not defined the address of the Thing but the address of the chanel. I have selected the Gateway in the binding and left the rest default. I have specified the Chanel Address, selected Switch, set the Chanel ID as 1 and put “Lightning” as the label. Then I have linked that chanel to a item switch labeled with “Lightning” and Category as “Light”, as I am trying to then emulate that KNX device as a philips hue light to be controlled by Alexa. I have only found this article, however didnt get it to work:


Please be aware that there is a difference between . and /

The individual address (is physikalische Adresse in german) is written with dots, 0.0.0 to 15.15.255.
The GroupAddress is written with slashes, 0/0/0 to 31/7/255

Just because a thing is displayed as ONLINE, doesn’t mean it’s properly configured in all details.

As I have mentioned, the local device address is set properly to 1.0.12 of the actual KNX interface. The only place I have define a Group Address is in the chanel. As far as I have seen, everything else requires the device address. Am I wrong?

Well, no? What you did mention is

I have set up the bridge correctly and it displays it as online.

But how do you know you set it up correctly when the connection doesn’t work properly?

You wrote

This notation is wrong and won’t work. Instead you have to use 9/0/1

Well, the individual address of the bridge must be an unused one, NOT the individual address of the knx interface.

Okay, thank you very much for the clarification. So I have to set the bridge to an unused device address like 99.99.99 and set the knx device to the address of the actuator?

Simply set the IP interface to 0.0.0.
At the switch actuator thing set the actual address to the device address on the bus (e.g. 1.1.2) as defined in ETS and select your interface in the bridge selection.
Then configure a switch channel and set its address to the group address for switching as setup in ETS. You may add the group address for reading the status, so you have a proper state representation (on/off) in OH.
(First group address is the switching channel of the actor, the second the status group address for that actors channel). Your values will differ.

Then add an item for that channel and happily switch your bulb :wink:


Please be aware that 99.99.99 is not an allowed individual address at all, as the scope is 0 to 15 for the first and the second part and 0 to 255 for the third part. Please be aware that 0 has a special meaning in all three parts. The individual addresses are not simply “set 16 bits as you want”. If you’re only using knx but don’t change settings through ETS, don’t think about individual addresses at all, just don’t set localSourceAddr at all or set it to “0.0.0” as suggested by @Oggerschummer
In question of the Things, you can keep it simple and just use one generic thing without any configuration (no address, no fetch, no pingInterval, no readInterval), then just add all your channels as channels and link them to the corresponding items. Or use the “one thing per device” option. Then if setting the correct address and pingInterval!=0 (maybe 300) you will get information about the ONLINE status of the device, but to be honest, this information is not that useful when using knx TP (twisted pair), it may be a nice feature when it comes to knx PL (power line) or knx RF (radio frequency), I don’t know as I only use TP.

Okay, thank you both very much. Here is the setup how I have it:

I still cant get it to work… Is there anything configured wrong?


Apparently I have reached the maximum replies and couldnt attach more than one picture very post, since the different posts. Anyways, apparently I wont be able to post anything for the next 4 hours, so if any one of you has time to reach out, here are some ways of conatcting me:
Skype: live:philip.schmid1142
Discord: Philip#6291
Phone: +41 76 250 25 55


Hm. Something in openhab.log about the bridge and the thing?
In your last posting, the openHAB knx channel should be [ ga="1/1/103" ]. A better view would be the one from the actuator (right window is all KOs from the actuator with all set GAs).
DALI is a bit special, because there might be no sufficient GAs for individual dimmers (depends on the configuration and DALI gateway…) I have no DALI…
Do you have some simple switch actuators? That would be a nice point to start.

As far as I can see we only have dali and then the physical switches to be used. I tried with those aswell, no luck. Where do I find the knx log? I can only find Openhab and a few others

There is no knx.log but only openhab.log :slight_smile: and in this log you will find some informations about knx, at least it should show informations about the bridge getting online, things being added and so on.

Okay, so I have managed to make it work now. I can control them via the control tab and am getting feedback. Next problem arrises. Im not able to make hue emulation working, does anyone of you have any experience with that?

No, sorry, I don’t have any Hues here.