Can't get OpenHab to work on Windows

  • Platform information:
    • Hardware: Core i5-7200, 8GB ram, 237GB SSD (162GB free)
    • OS: Windows 10
    • Java Runtime Environment: I’ve tried Zulu 10, Zulu 11, and jre1.8.0_181
    • openHAB version: 2.3.0
  • Issue of the topic: After installation, openhab won’t run

I’ve tried installing openHAB 2.3.0 manually using both zulu-10 and zulu-11. I have also tried installing using Chocolaty which installed jre1.8.0_181.

I get the following error message:

Launching the openHAB runtime...
-Djava.endorsed.dirs=C:\Program Files\Zulu\zulu-10\jre\lib\endorsed;C:\Program Files\Zulu\zulu-10\lib\endorsed;C:\ProgramData\chocolatey\lib\openhab\tools\runtime\bin\..\lib\endorsed is not supported. Endorsed standards and standalone APIs
in modular form will be supported via the concept of upgradeable modules.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Note that the error message is the same regardless of which java installation I point the JAVA_HOME environment variable to. I’d like to try openHAB out, but I can’t.

Does anyone know what’s going on here and how I can get it to install?



I don’t believe OH will run on version 10 of Java. You need to install one of the variants of 8.0

Make sure you also set the Java_Home Windows System Enviromental Variable


1 Like

As I pointed out in the original post, one of my attempts was with Chocolaty, which installed Java 8. Even then, and with changing my JAVA_HOME system environment variable to point to the Java 8 location, I still got the exact same message as above.

This error message come from Java 9 and above…you may still have something pointing to the 10.x version of Java,

Is there a reason you are using the package manager and not just installing on Windows…

The standard windows install is dead simple.


JAVA_HOME is pointing to the Java 8 installation. It would be helpful if someone can suggest where to look to correct this.

I started with the standard windows install, but that didn’t work because I installed Zulu-10. Many of the OpenHab docs are pretty old, and so when I read this about the prerequisites:

As for now, a pre-release Java 9 installation is not recommended and is not yet supported by openHAB 2.

I just assumed that was out of date since we’re no longer at Java 9 pre-release, but actually at fully released Java 10. It would be helpful to clarify the documentation to state that no Java version above 8 should be used.

In any event, I went the choco route after the standard install didn’t work.