Can't get start.bat script to run

  • Platform information:
    • Hardware: _Dual Core E7400
    • OS: Windows 10
    • Java Runtime Environment: _ Oracle

After several attempts at trying to get the system variable to stick. I got a diffrent error message “Launching the openHAB runtime…
WARNING: Running Karaf on a Java HotSpot Client VM because server-mode is not available.
Install Java Developer Kit to fix this.
For more details see http://java.sun.com/products/hotspot/whitepaper.html#client
The system cannot find the path specified.”

So then i uninstalled oracle and tried to install Zulu, using the SE8 file, because it was the only one that still had a 32 bit version, and that’s what the instructions say.

So I unziped the file, like the other instructions say, and tried to do a checksum on the msi file, like the instructions say… Except that there is NO msi file in the download.

and so here i am

update: reinstalled oracle 8 using developers kit, tried to run the start.bat and got the original message

"C:\openHAB2>start.bat
Launching the openHAB runtime…
JAVA_HOME is not valid: “C:\Program Files (x86)\Java\jre1.8.0_151\bin\java.exe”
The system cannot find the batch label specified - END
karaf.bat: JAVA_HOME is not valid: “C:\Program Files (x86)\Java\jre1.8.0_151\bin\java.exe”

that’s where the java is installed, am i supposed to use the exact variable that’s in the setup instructions? Because i couldn’t get that to work either

You need to have the JDK installed, not the JRE. Perhaps that is the difference? Beyond that

Please use the 32-bit version of the JVM for ARM platforms,

An Intel Dual Core E7400 is NOT an ARM platform. You will find ARM on Single Board Computers like Raspberry Pis. So you should download and use the 64-bit Java SDK 8 for Zulu.

set JAVA_HOME to the root of the JDK dir (not to the java executable)

C:\Program Files\Java\jdk1.8.0_172

Ref: https://www.openhab.org/docs/installation/windows.html#prerequisites

2 Likes