Can't get started with Homematic Binding

Hi everyone,

I am new to openHAB2 and tried the last week to get my openHAB2 (running new newest Version from cloudbees on a raspberry Pi3) with Homematic CCU2 working. I am not using Homegear. I was following a few different tutorials using the Eclipse Smarthome Designer and the documantary on github.

But I have a few troubles with it:

  1. I can connect openhab2 with my CCU2 via Paper UI (status online), but no item or any of my devices will be found. And the .thing file created via SmarthomeDesigner (after I deleted the homematic bridge) doesn’t work either.
    My homematic.thing:
Bridge homematic:bridge:ccu [ gatewayAddress="192.168.***.***"]{
	Thing HM-LC-Sw2-FM    LEQ0****	"Licht Thomas"  @  "Thomas"
	Thing HM-LC-Sw2-FM    MEQ***	"Licht Eesszimmer"  @  "Esszimmer"
  1. I tried to create a sitemap with following code in my first.sitemap, but there is no frame in my Paper UI:
sitemap Home label="Zuhause" {
  Frame label="Gruppen" {
  		Group item=gLicht
  		Group item=gThomas
  		Group item=gEsszimmer
  Frame label="Homematic" {
      Switch item=licht_thomas
      Switch item=licht_esszimmer 
  1. I created a first.items and in Paper UI the items are visible but I am not able to switch anything. There is no connection to the CCU2
    My first.items:
Group gLicht
Group gThomas
Group gEsszimmer

Switch licht_thomas "Thomas Licht" <light> (gLicht, gThomas) ["Lighting"] {channel="homematic:HM-LC-Sw2-FM:ccu:LEQ*****:1#PRESS_SHORT"}
Switch licht_esszimmer "Thomas Esszimmer" <light> (gLicht, gEsszimmer) ["Lighting"] {channel="homematic:HM-LC-Sw2-FM:ccu:MEQ******:1#PRESS_SHORT"}

My Echo Dot finds the two switches with Hue_Emulation Service.

Any futher google research was unsuccessful.

What am I doing wrong?

Thank you all for your help!

I also have been struggling with the homematic 2.0 binding for some time and then switched to the 1.9x binding which is working without issues.

I had problems with the Hue Emulation service though. Maybe the [“Lighting”] does not work with a 1.9 item. For this I am using a workaround signing the [“Lighting”] to a virtual switch and with a rule I am switching the actual homematic switch.

Thank you for your fast reply!

I will try the 1.9x binding next days.
And give a little report, how it is doing.

Now I was looking for the 1.9.x Homematic Binding but can’t find it with my Paper UI.
Do I have to install it from an other source?

I deinstalled the 2.0 Binding, installed it again and added my CCU2. And look there my Inbox is filled with 57 new devices!

Thank you for your advice anyway!

Now erverything works fine!

The homematic binding as well as the Hue Emulation Service!