Cant get StartHome Designer to run on OS X (10.12.5)


When I try to start the Designer from Applications folder, I get an error message (and the application launch then terminates)

The log file (which is very verbose of course) you can find in this gist file:

Ok. So I see that there are lots of imports that overwrite some previous ones (I did have the old designer installed before, but that was a long time ago now) and then an issue with write permissions (I guess).
How do I get the application to launch now ?


I did a complete reinstall of Designer to get it to work (wasn’t in the mood to solve the issue) when my Designer did not start anymore. I use Windows 7, though.


Yes, reinstallation would work for me too, but on OS X installation of an application in 99% of cases is just drag it to the applications folder (and even that is not always required).

Of course removing the application and then reinstalling it does not solve the issue, so the application must be installing or requiring files from elsewhere too somehow. I have not yet been able to find the duplicate files though.

Does anyone have an idea of where designer stores files (including jar files) outside of the Application folder?

On Windows it stores files in the userdata folder called .eclipse.
Deleting that folder resets Designer to default … not sure how that is done on MAC …


Problem solved. I did remove the .eclipse directory before, but maybe I somehow did it in the wrong order. Or maybe the fact that I had omitted to remove .eclipse_keyring confused the issue somehow.

Anyway, I removed EVERTHING eclipse and reinstalled the application - now it works!


1 Like