Can't group items

I tried everything possible or impossible I found on this forum regarding groups, but I can’t get them to work.

Here is what I have in my .items file

Group iRoom

Switch LR “LR [%s]” (iRoom)
Switch LRi “LRi [%s]” (iRoom)

and here is output from json request

“members”: [],
“link”: “http://…/rest/items/iRoom”,
“state”: “NULL”,
“type”: “Group”,
“name”: “iRoom”,
“tags”: [],
“groupNames”: []

Why there are no members ?


I would start with the basic stuff in the docs:

Thanks for suggestion and link. As I mentioned I already tried everything I could, including reading manual.

I don’t see anything wrong with my config file.

just recently someone had the problem that OH stopped “reading” his items-file after a certain line and never parsed the rest.
Maybe you have the same issue? Happens sometimes when you edit files in a windows environment and transfer them to linux afterwards. try deleting the file and recreating it with nano or vi(if it’s really just three lines).

It is not “typo problem”. I use vi/nano for editing. .items file has 130 lines of code and everything works as expected, the only problem is groups.

Have you tried to restart OH, sometimes editing to much and rereading all the file confuses OH.


Restarted. Doesn’t help.

Instead of checking via json request, in karaf console try:
smarthome:items list LR*
output should list the items including Groups the are in
smarthome:items list iRoom
output should list how many members the group has
If output shows item as not belonging to Group iRoom and group members for iRoom as Zero…then i have no more idea.

For groups I see (Type=GroupItem, Members=0,…
For item (Type=SwitchItem, State=OFF, Label=LR, Category=null)

Brute force: replace “iRoom” with “gDammit” and see what happens…

same sh…t :frowning:

OK next try. Try to add the group to you seite map and if it is displayed. And please post the items and the sitemap here.


Solved. Restarted OH using shutdown instead of logout and worked. Weird.

Thanks everybody.