Cant make openHAB Cloud or the hue binding work with Echo dot to expose KNX Items

Tags: #<Tag:0x00007f616d921a78>

I have already done that, had a switch and a dimmer. Not sure if exactly like that, ill try now. Put another group address into the Dimmer chanel or leave it to one and add another chanel thats a switch?

Check to make sure there is no duplicates links in /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.link.ItemChannelLink.json

For items check in /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.items.Item.json

The above is for Linux OS so exact location may differ. If you find a duplicate item or link then stop OH first, then edit the file to remove it.

FYI: If all items we created via files then you would only see a { } inside the file.

No groups for now. Keep it simple till it’s working with Alexa use just a switch item and dimmer. If I misunderstood your question then please post a picture of PaperUI showing all listed channels available.

I have the possibility of either filling in the switching address into the dimmer or a separate switch item instead of into the dimmer item.
Here is my ItemChanelLink.Json

{
“Kitchen_LED -\u003e knx:device:9247b975:V”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“9247b975”,
“V”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “Kitchen_LED”
}
},
“Office -\u003e knx:device:9a0e73eb:A”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“9a0e73eb”,
“A”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “Office”
}
},
“Kitchen -\u003e knx:device:d0d3f46e:A”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“d0d3f46e”,
“A”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “Kitchen”
}
},
“SamsungTV_Power -\u003e samsungtv:tv:e185fad3:power”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“samsungtv”,
“tv”,
“e185fad3”,
“power”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “SamsungTV_Power”
}
},
“Kitchen -\u003e knx:device:67efb2d0:Light”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“67efb2d0”,
“Light”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “Kitchen”
}
},
“SamsungTV_Power -\u003e samsungtv:tv:655c8dc9_4a3f_455e_b70c_73fe9f998629:power”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“samsungtv”,
“tv”,
“655c8dc9_4a3f_455e_b70c_73fe9f998629”,
“power”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “SamsungTV_Power”
}
},
“Kitchen_LED -\u003e knx:device:9247b975:v”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“9247b975”,
“v”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “Kitchen_LED”
}
},
“OfficeTest_Light -\u003e knx:device:9a0e73eb:C”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“9a0e73eb”,
“C”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “OfficeTest_Light”
}
},
“Kitchen -\u003e knx:device:a05b4875:A”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“a05b4875”,
“A”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “Kitchen”
}
},
“Kitchen -\u003e knx:device:67efb2d0:Lightning”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“67efb2d0”,
“Lightning”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “Kitchen”
}
},
“ONVIFGenericIPCameraWithONVIFSupport_RTSPURL -\u003e ipcamera:ONVIF:2feac815:rtspUrl”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“ipcamera”,
“ONVIF”,
“2feac815”,
“rtspUrl”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “ONVIFGenericIPCameraWithONVIFSupport_RTSPURL”
}
},
“Kitchen -\u003e knx:device:a05b4875:1”: {
“class”: “org.eclipse.smarthome.core.thing.link.ItemChannelLink”,
“value”: {
“channelUID”: {
“segments”: [
“knx”,
“device”,
“a05b4875”,
“1”
]
},
“configuration”: {
“properties”: {
“profile”: “system:default”
}
},
“itemName”: “Kitchen”
}
}
}

And here the items.item.json

{
“Office”: {
“class”: “org.eclipse.smarthome.core.items.ManagedItemProvider$PersistedItem”,
“value”: {
“groupNames”: [],
“itemType”: “Switch”,
“tags”: [],
“label”: “werf”
}

I didn’t see a link with the exact channel info but you have a lot of items named Kitchen. Maybe that is a reason Alexa is confused? Is there another device you can use to test with?

I have just used your example and renamed it and changed chanelID, its working now. Do you know how I can say “Alexa, Kitchen Spots On” and “Alexa, Kitchen Spots 100” or “Alexa, Kitchen Spots 50” instead of “Alexa, Kitchen Spots Light Level 50”?

:+1: Good to hear.

The name in my example is “Bed Room Light Level” so you should be able to change the name to just “Kitchen Light Level”, “Kitchen Brightness” or whatever you like.

You can also change the name Alexa uses via the Alexa app. :wink:

Figured it out, I grouped the Light level and Light switch to one group within Alexa so now its “Alexa, turn on Kitchen Lights” or “Alexa, Kitchen Lights to 50%” and it turns them on or dims them to 50% respectively. Thank you very much for the help!

1 Like

But you haven’t tried the V3 syntax yet. :dizzy_face:

With this you can ask Alexa to “Turn Light Switch …” on or off as well as “Set Light Switch to …” a certain percentage.

Dimmer LightSwitch "Light Switch" {alexa="PowerController.powerState,BrightnessController.brightness"}

The item would look like this:

Dimmer BedroomLight_Level "Bedroom Light Level [%.0f %%]"    <light> ["Lighting"]  { channel="mqtt:topic:pibroker:zigbee2mqtt:dimmer", alexa="PowerController.powerState,BrightnessController.brightness" }

Sorry, whats the difference? Feeling stupid asking this question :joy:

You can use just the Dimmer item to control both ON/OFF and Brightness. My example above was an old copy no longer used and the main objective was to get Alexa to control. Now it works you can optimize it with alexa=“PowerController.powerState,BrightnessController.brightness”. :wink:

I dont understand that part, incapable. Sorry :joy:

Remove the device from the Alexa app then change the item configuration and rediscover it with the app.

Item example:

Dimmer BedroomLight_Level "Bedroom Light Level [%.0f %%]"    <light> ["Lighting"]  { channel="mqtt:topic:pibroker:zigbee2mqtt:dimmer", alexa="PowerController.powerState,BrightnessController.brightness" }

You are only adding the alexa=“PowerController.powerState,BrightnessController.brightness” part to the end of your dimmer item. You can now comment out the switch item and have full control with single Dimmer item.

Oh okay, Thank you very much!
I just tried adding that behind the dimmer item, and commented out the switches. Alexa shows them on but they dont actually turn on. Any clue?

If you deleted the light in Alexa app and rediscovered then you may also need to move the item to a new file or rename the existing file. After the file move/rename then rediscover with the app and see if that helps.

Only other thing would be the switch in OH is hanging around in the cache so stopping OH and cleaning cache would fix that but try the above first.

During the process of commenting out the adjusted dimmer in order to have it working temporarily, I think I did something I shouldnt have. Now the KNX.items file wont create any items nor will it link them. Have you got any idea on how to fix it?

Switch KitchenSpots “Kitchen Spots” [“Lighting”] { channel=“knx:device:233be9c4:V”, expire=“120m,command=OFF” }
//Dimmer KitchenSpotsLightLevel “Kitchen Spots Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:233be9c4:F”, alexa=“PowerController.powerState,BrightnessController.brightness” }
Dimmer KitchenSpotsLightLevel “Kitchen Spots Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:233be9c4:F” }

Switch KitchenLED “Kitchen LED” [“Lighting”] { channel=“knx:device:da63c065:V”, expire=“120m,command=OFF” }
//Dimmer KitchenLEDLightLevel “Kitchen LED Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:da63c065:F”, alexa=“PowerController.powerState,BrightnessController.brightness” }
Dimmer KitchenLEDLightLevel “Kitchen LED Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:da63c065:F”, }

Switch DiningRoom “Dining Room” [“Lighting”] { channel=“knx:device:4c14aa0c:F”, expire=“120m,command=OFF” }
//Dimmer DiningRoomLightLevel “Dining Room Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:4c14aa0c:f”, alexa=“PowerController.powerState,BrightnessController.brightness” }
Dimmer DiningRoomLightLevel “Dining Room Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:4c14aa0c:f” }

Switch LivingRoomSpots “Living Room Spots” [“Lighting”] { channel=“knx:device:d2f04964:F”, expire=“120m,command=OFF” }
//Dimmer LivingRoomSpotsLightLevel “Living Room Spots Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:d2f04964:D”, alexa=“PowerController.powerState,BrightnessController.brightness” }
Dimmer LivingRoomSpotsLightLevel “Living Room Spots Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:d2f04964:D”}

Switch LivingRoomLED “Living Room LED” [“Lighting”] { channel=“knx:device:d2f04964:T”, expire=“120m,command=OFF” }
Dimmer LivingRoomLEDLightLevel “Living Room LED Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:d2f04964:Z”}
//Dimmer LivingRoomLEDLightLevel “Living Room LED Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:d2f04964:Z”, alexa=“PowerController.powerState,BrightnessController.brightness” }

//Switch Entrance “Entrance” [“Lighting”] { channel=“knx:device:8cf3d7bd:R”, expire=“120m,command=OFF” }
//Dimmer EntranceLightLevel “Entrance LED Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:8cf3d7bd:T”, alexa=“PowerController.powerState,BrightnessController.brightness” }
Dimmer EntranceLightLevel “Entrance LED Light Level [%.0f %%]” [“Lighting”] { channel=“knx:device:8cf3d7bd:T”,}

Switch RampFacadeAmbient “Ramp Ambient Facade” [“Lighting”] { channel=“knx:device:221f7a7a:F”, expire=“120m,command=OFF” }

Switch GroundFloor “Ground Floor” [“Lighting”] { channel=“knx:device:ef12bbec:F”, expire=“120m,command=OFF” }

Switch FirstFloor “First Floor” [“Lighting”] { channel=“knx:device:cdd0324d:F”, expire=“120m,command=OFF” }

Switch AllLights “All Lights” [“Lighting”] { channel=“knx:device:80833343:F”, expire=“120m,command=OFF” }