Can't reinstall the dev environment

(Kai Kreuzer) #21

As the validation tells you, you need to add org.eclipse.smarthome.io.http to the launch config - this is a recently added bundle that wasn’t yet added to the launch config - I’ve just added it now.

0 Likes

(Slaviša Lukić) #22

Tried today to install ide on my new laptop, getting this error after pressing finish:

Fetching p2.index from http://download.eclipse.org/releases/2018-12/201812191000/
Fetching p2.index from http://download.eclipse.org/technology/epp/packages/2018-12/
Fetching p2.index from http://download.eclipse.org/releases/2018-12/201812191000/
Adding repository http://download.eclipse.org/technology/epp/packages/2018-12
Adding repository http://download.eclipse.org/releases/2018-12/201812191000
Fetching compositeContent.jar from http://download.eclipse.org/oomph/updates/milestone/latest/ (440B)
Fetching content.xml.xz from http://download.eclipse.org/egit/updates/
Fetching content.jar from http://dist.springsource.org/snapshot/GRECLIPSE/e4.8/ (11.14kB)
Fetching content.xml.xz from http://download.eclipse.org/technology/epp/packages/2018-12/
Fetching content.xml.xz from http://download.eclipse.org/releases/2018-12/201812191000/
Fetching content.jar from http://download.eclipse.org/oomph/drops/milestone/S20170307-122318-1.7.0-M4/ (36.91kB)
Fetching content.xml.xz from http://download.eclipse.org/releases/2018-12/201812191000/
Calculating requirements and dependencies.
Cannot complete the request.  Generating details.
ERROR: org.eclipse.equinox.p2.director code=10054 Cannot complete the install because of a conflicting dependency.
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:425)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:337)
  at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:733)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3334)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3262)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3243)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3143)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:575)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:701)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
  ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1547553668795
  ERROR: org.eclipse.equinox.p2.director code=1 Only one of the following can be installed at once: 
    ERROR: org.eclipse.equinox.p2.director code=0 Java Development Tools Core 3.14.0.xx-201901150528-e48 (org.eclipse.jdt.core 3.14.0.xx-201901150528-e48)
    ERROR: org.eclipse.equinox.p2.director code=0 Java Development Tools Core 3.16.0.v20181130-1748 (org.eclipse.jdt.core 3.16.0.v20181130-1748)
    ERROR: org.eclipse.equinox.p2.director code=0 Object Teams Development Tooling Core 3.16.0.OTDT_r272_201812061254 (org.eclipse.jdt.core 3.16.0.OTDT_r272_201812061254)
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1547553668795
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.codehaus.groovy.eclipse.feature.feature.group 0.0.0
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1547553668795
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.jdt.feature.group 0.0.0
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: Groovy-Eclipse Compilerless feature 3.3.0.xx-201901150528-e48 (org.codehaus.groovy.compilerless.feature.feature.group 3.3.0.xx-201901150528-e48)
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.codehaus.groovy.headless.feature.feature.group [3.3.0.xx-201901150528-e48,3.3.0.xx-201901150528-e48]
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse Groovy Development Tools 3.3.0.xx-201901150528-e48 (org.codehaus.groovy.eclipse.feature.feature.group 3.3.0.xx-201901150528-e48)
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.codehaus.groovy.compilerless.feature.feature.group [3.3.0.xx-201901150528-e48,3.3.0.xx-201901150528-e48]
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: Groovy-Eclipse Headless feature 3.3.0.xx-201901150528-e48 (org.codehaus.groovy.headless.feature.feature.group 3.3.0.xx-201901150528-e48)
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.codehaus.groovy.jdt.patch.feature.group [3.3.0.xx-201901150528-e48,3.3.0.xx-201901150528-e48]
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: JDI Debug UI 3.10.100.v20181120-0542 (org.eclipse.jdt.debug.ui 3.10.100.v20181120-0542)
    ERROR: org.eclipse.equinox.p2.director code=0 To: osgi.bundle; org.eclipse.jdt.core [3.15.0,4.0.0)
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse Java Development Tools 3.16.0.v20181206-1038 (org.eclipse.jdt.feature.group 3.16.0.v20181206-1038)
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.jdt.debug.ui [3.10.100.v20181120-0542,3.10.100.v20181120-0542]
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From Patch: org.codehaus.groovy.jdt.patch.feature.group 3.3.0.xx-201901150528-e48 Eclipse Java Development Tools 3.16.0.v20181206-1038 (org.eclipse.jdt.feature.group 3.16.0.v20181206-1038)
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.jdt.core [3.14.0.xx-201901150528-e48,3.14.0.xx-201901150528-e48]

Took 9 seconds.
There are failed tasks.
Press Back to choose different settings or Cancel to abort.
0 Likes

(Hilbrand Bouwkamp) #23

At least try the supported eclipse version: Photon. Newer versions are not (yet) supported, therefore I wouldn’t know if your errors are due to the eclipse version or something else.
The advice I posted is outdated so I’m striking it through to avoid people from follow the wrong advice if they find this post

0 Likes

(Slaviša Lukić) #24

Looking for the installation package.

Here I am not able to find the installer which starts the same installation procedure as described

https://www.eclipse.org/downloads/packages/release/photon/r

0 Likes

(Hilbrand Bouwkamp) #25

With the eclipse installer https://www.eclipse.org/downloads/packages/installer you can select a specific eclipse version. The installation (covers openHAB and eclipse Smart Home) procedure is describrd here: https://www.eclipse.org/smarthome/documentation/development/ide.html

0 Likes

(Slaviša Lukić) #26

thanks, got it now. Did not see a selection at that step

0 Likes

(Markus Michels) #27

you need to open the advanced menu (upper right corner) and do an update
select Eclipse IDE for Java Developers[Next]
after that you could select which components to install
make the selection of openHAB repositories[Next]
this will install the dev environment and repos (first run of Eclipse)

0 Likes