Cant yum update to latest snapshot

Tags: #<Tag:0x00007f616df69340>

Hello,

On centsos 7 I’m trying to ‘yum update’ to the latest snapshot release, but I get an signature error.

My repo config:

[openHAB-Snapshots]
name=openHAB 2.x.x Snapshots
baseurl=https://openhab.jfrog.io/openhab/openhab-linuxpkg-rpm/unstable
gpgcheck=1
gpgkey=https://bintray.com/user/downloadSubjectPublicKey?username=openhab
enabled=1

The error:

---> Package openhab2.noarch 0:2.5.6~S146-1 will be updated
---> Package openhab2.noarch 0:2.5.7~S163-1 will be an update
error: skipping package /var/cache/yum/x86_64/7/openHAB-Snapshots/packages/openhab2-2.5.7~S163-1.noarch.rpm with unverifiable signature

Have tried to disable pgp check, then I get this error:

Transaction check error:
  Unknown error during transaction test in RPM

Something wrong with the latest package?

(edit: sorry wrong repo in original post, corrected)

Kind regards,
Bastiaan

Hi @bastiaan_van_h, is S164 doing the same thing? I’ve tested on Fedora 32, and this the signature check is passing, I don’t think there’s been any changes in the packages since S146.

Try clearing the yum cache before trying again.

Hi @Benjy, upgrading to S164 goes fine. I then cleared the yum cache, and tried downgrading to 163 and again the signature warning.

I did some tests:
162 = OK
163 = signature fault
164 = OK

Perhaps something went wrong with the build process of 163, but as 164 is fine I will use this one.

Thanks @bastiaan_van_h, sorry for not checking that package specifically. I’m getting the same error for that specific package version.

There’s no difference between how S163 and S164 were created. The offline add-ons package for S163 (openhab2-addons-2.5.7~S163-1.noarch.rpm) has a valid signature even though this would have been created under the same settings and environment.

I’ll keep an eye on it and the build logs, but not sure if there’s anything that can be done at this point. Would you be able to post here if it happens to you again?

@Benjy, no worries, yes will do.