Chamberlain MyQ Binding

I’ll look at this over the weekend and see if i get can a fix for now.


Thanks for all the efforts. This binding supports one the the features that my wife finds most useful.

Thanks Dan, would it be possible for you to fix the 2.5.x version also? There are a bunch of people that still haven’t upgraded to to the 3.x version.

Best, Jay

1 Like

I’m seeing the same issue as the others too, as of this morning. Available to help test any changes that come out.

Just a quick update, i have the binding working again, i need to clean it up quite a bit as the authentication was very complicated, but should get it done this week. I’ll post a beta version as soon as i have proper error handling ready.

It’s not really feasible to build against 2.x anymore, for one the 2.x build system is no longer available afaik, and second is that the 3.0 version of myq is a complete rewrite, so it’s not possible to back port these changes.


I have a first draft build, note that you will need at least OH 3.1 i believe (its built against 3.2, but should be compatible)

see Release MyQ oAuth · digitaldan/openhab-addons · GitHub

Download the jar and either put it in the addons folder OR upgrade the current installed one by running:

bundle:update org.openhab.binding.myq file:////some/path/org.openhab.binding.myq-3.2.0-SNAPSHOT.jar

from the OH CLI (karaf console). If dropping into the addons folder, you may need to uninstall the existing one first.

This is dependent on a 3rd party library that would normally be installed automatically, but since we are manually loading this jar, you may need to install it manually. This can be done with the OH CLI (karaf console) like so:


I’m waiting to see if token refreshes work, as well as general clean up. I’ll open a WIP PR today so others can see the code changes


Followed instructions above and it appears to be working for me. It does not seem to require the jsoup bundle for me.

Super-appreciate the hard work on this! Happy to buy you a coffee or pint!

Working for me as well.
Thanks a lot Dan for your hard work! Really appreciate!

Works like a charm for me on OH3.2.0M1.

  • old MyQ binding removed via mainui
  • new MyQ jar added to the addons folder
  • jsoup added as per notes above
  • restart openhab

The existing MyQ items reconnected and all now works.
Thx much!

Working for me as well with docker based on image openhab/openhab:3.1.0

Thanks a lot Dan!

PR [myq] Switch to using oAuth for logins by digitaldan · Pull Request #11183 · openhab/openhab-addons · GitHub</t

Thanks for he quick turnaround @digitaldan! Working great for me.

Thanks @digitaldan! Guess I’ll need to upgrade from 2.5.12 to 3.x for this. I love the features in this binding!

So far this is looking good, i can see its refreshing the token every 5 mins, I’ll prepare the PR for review this weekend. Thanks for all the positive feedback, appreciate it!

Working great for me using the latest snapshot. I downloaded and dropped the jar into my addons directory. Then needed add jsoup.


Works fine with 3.2.0.M2 update released this morning. I did notice that after clearing the openhab cache I needed to re-add jsoup via the console before the MyQ binding would connect.


Same for me. After re-installing the jsoup bundle and restarting the myq binding it’s all happy once again

Everything worked great!

I am on OH 3.1.0M1

Here are the steps I took:

  1. Downloaded the new binding jar file.
  2. Renamed it to “org.openhab.binding.myq-3.1.0.M1-SNAPSHOT.jar” and dropped it into the addons folder, replacing the old one.
  3. Ran “bundle:install” in the karaf console
  4. Restarted OH

Thanks @digitaldan

1 Like

Thanks again for this. To be sure, there probably isn’t a way to shoe horn this into 2.5?
I installed & started jsoup but the 3.1 myq won’t start and kicks out error:

Error executing command: Error executing command on bundles:
Error starting bundle 273: Could not resolve module: org.openhab.binding.myq [273]
Unresolved requirement: Import-Package: org.openhab.core.auth.client.oauth2

I’ll look around but wasn’t able to find that package to import with a quick search, and I’m not sure this would resolve all the requirements anyway.

I’ll have to bite the bullet and do the 2.5 → 3.x migration. I may move to new hardware so I don’t have to worry about trying to restore if I have any issues.

I am running openHAB 3.1.0 and installed this binding by dropping it in my add-ons folder. I also installed jsoup and restarted openhab.

MyQ Binding is showing as ‘Active’ and Jsoup is showing as ‘Resolved’ when I run bundle:list in karaf.

I added my MyQ Account thing and my garage door.
Account shows Online but garage door shows as Unknown.

any ideas?