Chamberlain MYQ Garage Door Control with new cloud connector


Trying to figure out where things went south. I original followed the following tutorial at and everything was working great.

I then installed the cloud connector and everything worked on the openhab side (I can open/close the door via the web app).

When I get to this section: For the +That part, choose openHAB

For Choose action, pick “Send a command”

Under “Complete Action Fields”, the item will be “GarageDoorSwitch”

The Send a command under Complete Action Fields has “Options unavailable” instead of “GarageDoorSwitch”

Any ideas how to troubleshoot?


It’s not working yet:

I think the IFTTT update took longer than expected by I do see GarageDoorSwitch in my IFTTT applets.

Initially these were showing up as “Loading Items”

Is it working for everyone else?

I just went through the blog again with a fine tooth comb and no luck. I think the only changes that need to be made are adding the cloud.jar file to the addons folder AND adding the new lines to the openhab.cfg. I broke the link between IFTTT/openhab and re authenticated. Everything works in openhab…I see the notifications, I’m online, and I can hit the open/close button. I always get the 'No options found" instead of the garagedoorswitch when I use the applet maker.

Using 1.8.3 on windows.



In do you see the GarageDoorSwitch listed under items?

If not, it won’t work.

If you do NOT see it listed there under Items:

Make sure it is exposed using the new cloud config in openhab.cfg:

Also may need to manually open/close the Garage Door so that status updates get sent to


I followed the same tutorial as zeenon. I’m also unable to see any openhab commands in IFTTT anymore. I added the openhabcloud.jar file, removed the myopenhab.jar file and updated openhab.cfg. Is this all that is required?

I’m getting garagedoor related notifications (manual & openhab), but GarageDoorSwitch isn’t listed under items. I’m able to open/close the garage door via http://192.168.x.xx:8080/

Good Day, I am new as well to the Alexa Christmas item and was wondering with the new cloud connector if there are additional clarification documentation. All is communicating except no notifications yet.

Did you re-authenticate IFTT with your new account?

Maybe you are affected by this bug:

Assuming you had it working before cloud, please see the editors note here for update instructions after cloud.


Thanks for the info.

Yup. On IFTTT: URL= & Status=active.

Thought I found my mistake - didn’t update openhabcloud:expose=GarageDoorSwitch in openhab.cfg. However, still not seeing items in openhab or IFTTT.

openhab update GarageDoorSwitch ON - update sent successfully (I don’t see the debug line).

Update: restarted openhab and it’s working now! Thanks for the help guys.

I got it working also. I almost certain the openhabcloud:expose=GarageDoorSwitch in openhab.cfg fixed the issue.

Although watch out, I copied the line direct from wemustbegeeks which is garagedoorswitch and it still was not working then I said to myself let me try caps - GarageDoorSwitch and it started working within 30 secs.


1 Like