Change brightness level smoothly on GE/Jasco Dimmers (12724, 45715)

So I contacted Jasco support and here is what I have found out so far:

I spoke to the product manager this morning because I am getting more emails about this issue so I wanted to be sure there isn’t a problem with our dimmers that we weren’t aware of. He said that current Z-wave dimmers had a firmware update some time ago and this new firmware that Z-wave required is the cause of this problem. It basically says that anytime there is a command to turn the light on or dim it up it will go that level instantly instead of ramping up like we are used to. the current switches cant adjust or disable this feature. The next version of switches will have the ability to turn this feature on/off and adjust the actual time it take to go from 0% light level to 100%, but there is no ETA on when these dimmers will be out. On the back of the switch it will show the version number, ver.3.0D is the old version and the light will go up/down like it always has, ver.3.0E is the updated firmware.

It seems that recent firmware versions of the GE/Jasco dimmers are simply broken and do not support changing the brightness level smoothly. I can’t imagine what led them to believe that it was acceptable to sell dimmers with that behavior. Maybe you got lucky @feens and got dimmers with the older firmware which works correctly.

I am going to continue trying to talk to Jasco to see if I can get some sort of a solution or get some of my money back for these crappy dimmers :unamused:

I just went and actually tested mine with the web interface vs the switch itself, and I guess mine do respond instantly via the UI vs switch itself, though I don’t find it to be that noticeable to be honest.

No - you can’t change the command class version - this is set by the device firmware.

I got an official response from Jasco. The firmware version 3.0E dimmers do not (and never will) support smoothly changing their brightness levels via zwave. The older 3.0D version should work correctly. They said their next version of dimmers which they called “500 series” will support this but they are not on the market yet. They told me that they would update their documentation to avoid further confusion.

They also offered me a refund for my dimmers which was very nice of them. I am going to take the refund and try the leviton dimmers instead.

Hey guys, I noticed with my GE 12722 on/off switches that the UI responds instantly to switch changes when I turn the switch on or off from the actual switch. With my GE 12724 when I’m switching it off the UI does respond to a change instantly but it still shows that the switch is on just a couple of percentages lower than where it started. If I hit down again on the switch while it is already off then it will show on the UI as actually being off. I saw over on the Home-Assistant forum that they were able to fix this problem by delaying the refresh rate to 3 seconds in order to allow the dimmer to finish it’s built in fade out. I was wondering if there was anyway to do this in openhab?

There is some discussion of it here State of GE Z-Wave dimmer model 12724 is not syncing

Basically it seems that the GE dimmers are fickle. They (sometimes) send status updates right when the paddle is pressed, but it always sends the wrong status because they are in the process of fading out. I tried a refresh rule like the one in the post I linked and it worked OK. I am returning all of my GE dimmers for a refund and am going to try out the Leviton ones. GE ones have too many quirks and I am annoyed with the amount of time I have spent trying to get them to work the way I want (which is actually impossible per my conversation with Jasco).

Any advice (or just an email address) for pursuing refunds on my GE dimmers/switches? This is a disappointing (and absurd) decision on the part of GE/Jasco.

Hey all, I realize that this a bit of an old thread, but I’m wondering if anyone knows how to tell if their GE/Jasco dimmers are Ver. 3.0D or 3.0E without having to take them out of the wall. I’ve got a bunch of them that I bought at different times and don’t want to have to pull them all out if I don’t have to.

I can pull the raw description off the device from Smartthings device listing, such as:
zw:L type:1101 mfr:0063 prod:4944 model:3031 ver:3.37 zwv:3.67 lib:06 cc:26,27,73,70,86,72,77

But I have no idea whether ver: 3.37 or any of the identifiers after that correspond to 3.0D vs. 3.0E etc?

Any help would be appreciated. I’m trying to use some of the enhanced device handlers that many of you good folks wrote in order to reduce the fade on and fade off times, but am having no luck.

Thanks in advance!