Channel not linking, when migration of 2.5 items file to OH3

  • Platform information:
    • Hardware: Dockers image
    • openHAB version: 3.0
  • Issue of the topic: Channel not linking, when migration of 2.5 item file to OH3

What I tried:
I try to move my configuration from 2.5.11 over to 3.0. I run both systems in parallel to use the migration to get some old outdated stuff out of my system.

I added all Things via UI discovery manually i.e.

Afterwards, I add the items of the equivalent thing, by UI:

This works perfectly.

The channel of the thing is not linked to the items - what I am doing wrong?

If I add channels via UI manually, it works, but I have 800 + items. Adding channels manual is no option to me.

What I am doing wrong? The items worked in OH2.5.11 perfectly.

Thanks in advance.

Are you trying to link dissimilar Items and channels e.g. number:temperature type channel to Number type Item? Channel types have changed in some bindings.

I did another test, where I have a 1:1 relationship (i.e. name thing = name item).
The first I did with Homematic binding -> same result as above
The second with Shelly binding -> which worked perfectly.

Is there something different with the Homematic binding? How could I add the ones for Homematic - do I really add them all manually?

Ok, I found the issue by my own. The name of the channel changed… Something, I could do follow up manually.