Chart is not shown anything neither the time


I want to install a chart on my sitemap, so that i can see the temperature in my house. I have tried a lot but the chart is shown nothing, Also the time is not shown correct below the chart. Please have a look to the photo.

Please find below my configuration:




Strategies {
everyMinute: “0 * * * * ?”
everyHour: “0 0 * * * ?”
everyDay: “0 0 0 * * ?”
default = everyChange
Items {
Ess_Temp_Ist : strategy = everyChange, everyMinute


Chart item=Ess_Temp_Ist period=h refresh=10000

I’m a little bit confused, because all problems i could find in other topics was with the values inside of the chart but not from the chart themself. Has someone an idea, where i have made a failure?

Besides the weird empty chart (there migth be something wrong with it too) I think you got to wait before anything can show up because of your custom setup of rrd4j.
You are using a single archive which is NOT saving a value for every minute (never tried it like that, not sure if it works).Your setup asks for an average over 720 minutes to entered in the database and you want to keep 730 values of those. Is that what you want, showing averages temperatures for 12hour periods?
The documentation on the archives should be clear, for further help on that just yell (that got to be loud in order to hear it here at 70°N😉)

Sorry for the late reply, but i was not at home the last days…

If have changes the archive to the example in the documentation, so it should store for 8 h every minute, for one day every 4 minutes and so on.


But my chart is showing the same than on the picture in my last post. What could be wrong with it?

If you changed the archive setup , you should at least delete the actual .rrd file in order to restart the persistence.
If that does not help you migth (also) suffer from a ( to me unexplained) problem. Please state your kind of setup (openHAB version, Java version and OS).
If you are using an openhabian setup, installing the option “InfluxDB+grafana” did overcome the issue.
Look here

BTW I’m back home as well.

You could have a look at this recent thread for ideas and investigative moves.

I have deleted the .rrd file and restarted open hab. I have installed open hab on my synology server and installed it with a spk package. At the moment I have the openhab 2 version and java 8 running.I have also installed the influxDB now, but can’t find the “grafana” persistance.

I tried to install the “RestAPI” interface, but I can’t choose this in my installation. Where can I find it?

I have also tried to read the other post “Problem: Chart generation failed:null”, but I’m not sure if this is the same problem, because I can see a chart, but without contend.

Installation of the RestAPI is done via REST Documentation (on PaperUI under AddOns- Misc).
After that it will show on the Dashboard.
And yes, I think your problem might not be related with the other thread.

installation grafana

sudo openhabian-config

Go to “20 Optional Components” > “24 InfluxDB+Grafana” <>
After installation and reboot:

1 Like

Indeed. The point was to check your data storage, without which you will get no chart content.

I have installed the REST API and have followed the instruction:persistance --> GET persistence/items/{itemname} --> insert item name “Ess_Temp_Ist” and get following results


curl -X GET --header "Accept: application/json" ""

Request URL

Response Body

  "name": "Ess_Temp_Ist",
  "datapoints": "0",
  "data": []

Response Code


Response Headers

"content-length": "50",
"content-type": "application/json",
"server": "Jetty(9.4.11.v20180605)"

I don’t know exactly what this mean, but it seems to me that there is saved nothing in the persistence, or?

The response body tells you, your database has 0 entries, in other words it is empty!
Did you delete the existing .rrd file ( to be found under var/lib/openhab2/persistence/rrd4j ) and restart either openhab or only the rrd4j bundle?`

I have deleted the file and restarted open hab completely, but my file is in (\public\openHAB\userdata\persistence\rrd4j) folder. Could be this the problem?

After deleting it, it will be insert new automatically in this folder.

The file structuredepends on host e.g. Windows will be different again.
xxx\userdata\persistence\rrd4j seems correct.

Next step might be to run a completely default rrd4j.cfg (again a restart would be needed)

Additionally, please post all relatied log lines after the restart.
Of coure only if it is not working.

Where can I find this log lines? is it in REST API under services?

Or do you mean my file on the server under services?
This is:

# configure specific rrd properties for given items in this file.
# please refer to the documentation available at
# default_numeric and default_other are internally defined defnames and are used as
# defaults when no other defname applies


Log-lines can be found in the log-Viewer ( to be found on your openHAB Dashboard).

In order to use only defaults for the rrd4j.cfg either delete the whole file or make every line a comment (a “#” at the start of each line will do).

I Font have a Log Viewer on my Dashboard, where can I Install it?

Can I deleted all Limes in the rrd4j.cfg, when i’m using only the default option, or have I to keep the “xxx.items”?

Yes, you can delete the whole file. That way the default archive-setup will be used for all items that are persisted (you could have several archive-setups, each of which to be used for a subset of your items). You have specified which items to persist in the file rrd4j.persist!

I have deleted all lines in the rrd4j.cfg, deleted the .rrd files and restarted openhab completely, but I have the same problem.

Can someone explain, how I can install the log files viewer on the dashboard? I can’t find it, I have only “home Builder”, “Rest API”, “Habpanel”, “Basi UI” and “Paper UI”.

I’m using an openhabian install to which it was installed automatically
For a manual setup look Here
If you do not want to install anything, you can either use the karaf console to show the logs (log:tail) or open the logs manually.