Charts is not shown in OH2

  • Platform information:
    • Hardware: Raspberry Pi3 B
    • OS:Debian
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2.3.0
      All was OK, but I tried another UIs. HABmin, HABpanel, and classic UI. After using Classic UI, after one reboot, Charts are not shown in Basic UI.
      it is with this massage
      javax.servlet.ServletException: Could not get chart provider.

I have read many topics, but I have no solution.

What persistence are you using?

Is it installed?

Is the persistence engine you are using set as the default?

1 Like

it is installated. it is RRD4J. In HABmin it works. I checked in PAPER ui - default persistence engine - it is rrd4j


Problem accessing /chart. Reason:

    Server Error

Caused by:

javax.servlet.ServletException: Could not get chart provider.
	at org.eclipse.smarthome.ui.internal.chart.ChartServlet.doGet(
	at javax.servlet.http.HttpServlet.service(
	at javax.servlet.http.HttpServlet.service(
	at org.eclipse.jetty.servlet.ServletHolder.handle(
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(
	at org.eclipse.jetty.servlet.ServletHandler.doScope(
	at org.eclipse.jetty.server.session.SessionHandler.doScope(
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(
	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
	at org.eclipse.jetty.server.Server.handle(
	at org.eclipse.jetty.server.HttpChannel.handle(
	at org.eclipse.jetty.server.HttpConnection.onFillable(
	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.executeProduceConsume(
	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceConsume(
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
	at org.eclipse.jetty.util.thread.QueuedThreadPool$

this link works too
The problem is still Basic UI.

OK, the basics are out of the way.

I think you will need to file an issue at

Make sure to emphasize that charts are working in the other UIs, just not in BasicUI.

1 Like

I wrote in last message. The charts work in other UIs. This seems like broken link for chart provider. I have to reinstall something? is there any general workaround to fix it?

You probably set the chart provider setting to an unexpected value. Only accepted value is “default”.

can I define it in /etc/openhab2/services/charts.cfg ? It was default. I try change to org.eclipse.smarthome.chart. code page must be UTF8 ?

after restart - it works. solved - with editing charts.cfg - without .ui

thanx to Lolodomo

I’ m new to mysql … it was working fine, but haven’t seen any data on chart. This was the hint:
Is the persistence engine you are using set as the default?
I had running mapdb as default. After the change to mqsql … data is on the chart!
Thx :sunglasses: