Classic UI fails because sitemap could not be found


Running new Openhabian install of openHAB 2.5.1-2 on a Raspberry Pi 2 (buster).

I still like to use the Classic UI occasionally from a couple of my desktops but it has quit working. When I try to launch it I get:

Problem accessing /classicui/app. Reason:

    Server Error

Caused by:

javax.servlet.ServletException: javax.servlet.ServletException: Sitemap 'hsh.sitemap' could not be found
	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
	at org.eclipse.jetty.server.Server.handle(
	at org.eclipse.jetty.server.HttpChannel.handle(
	at org.eclipse.jetty.server.HttpConnection.onFillable(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(
	at org.eclipse.jetty.util.thread.ReservedThreadExecutor$
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
	at org.eclipse.jetty.util.thread.QueuedThreadPool$
Caused by: javax.servlet.ServletException: Sitemap 'hsh.sitemap' could not be found
	at org.openhab.ui.classic.internal.servlet.WebAppServlet.service(
	at org.eclipse.jetty.servlet.ServletHolder.handle(
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(
	at org.eclipse.jetty.servlet.ServletHandler.doScope(
	at org.eclipse.jetty.server.session.SessionHandler.doScope(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(
	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(
	... 15 more
Caused by: org.openhab.ui.classic.internal.render.RenderException: Sitemap 'hsh.sitemap' could not be found
	at org.openhab.ui.classic.internal.servlet.WebAppServlet.service(
	... 33 more

But if I check the openhab.log file when openHAB is started I get:

2020-01-21 17:29:46.631 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'hsh.sitemap'
2020-01-21 17:29:47.034 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'influxdb.persist'
2020-01-21 17:29:47.382 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'hsh.items'
2020-01-21 17:30:07.665 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to.......

And my iPhone UI looks fine so the sitemap is OK. Why can’t Classic UI find it?

I checked the Classic UI service configuration in Paper UI and hsh.sitemap is shown as the default sitemap.

Any help appreciated.


Dies Basic UI work? Your iPhone is based off that. I think Classic UI was used for openHAB1. I have never used that UI.

HI Bruce,

Yes, I should have mentioned that Basic UI is working fine.
I should also mention that Classic UI was working fine last week on a previous install of the same version. I had to rebuild from scratch when I moved the server from a Pi 3 to the current Pi 2.

Have you made sure the ui is installed? Maybe in the move it did not get reinstalled.

1 Like

Hi Danny,

The Classic UI tile shows up on the “Welcome to openHAB2” page and if I look under add-ons, UIs, it shows as installed.

Just to be sure I uninstalled via Paper UI and then reinstalled. Still get the same Server error as above.

1 Like

Well worth a shot! Glad we know now!
I would run the fix permissions script in openhabian. That’s the last option I have.

1 Like

@Gibber in addition to fix permissions as @Thedannymullen mentioned I would also run add needed packages, and svr mounts.

I tried the above and no help. Then I noticed other strange behavior like missing bindings and icons. At that point I figured I must have a bad SD card. Rebuilt the system with a fresh card and all is well so far.

Thanks guys.


Another failed SD card, :expressionless: you may want to look at using an SSD as they will last longer.

Please click the square box on solution post to mark topic as solved.


1 Like