Classic UI formatting

I have successfully migrated from OH1 to OH2 but something has gone wrong with the classic UI formatting?

The label is on the right side of the value, rather than beside the icon and the line width is generally too small.

The sitemap was working 100% and went wrong while I was installing bindings and some actions - mySQL, Mail etc…

The basic UI is fine? Any ideas?

As you can see on (which runs openHAB 2), there is no general issue with the Classic UI. So I would assume that there is some bug in your sitemap/item file, which might have been accepted in openHAB1, but causes a problem in openHAB2 now. Can you provide a very simple item/sitemap file that provokes this error (e.g. a small change to the demo files)?

I recently encountered the same issue in OH1 when I used label="" in the item line in sitemap.
I didn’t check out all variations, but potentially it also happens when you either omit the label or define it in items. label=" " didn’t work either, so I used a barely visible character. If you happen to find a better workaround, let me know.
Or - better - find out the conditions and file it as an OH issue.

Thanks Kai. I had tried a simple sitemap, but didn’t cut the items file
down. I have now cleaned it up and while not exactly sure what fixed the
issue, have the classic UI working 100% again.

1 Like

Whoops - problem came back - reduced down to a single item and still same
issues - demo same too??

Something very interesting - on my old laptop(windows 7 -32bit) the UI looks and works 100%, while at the same time on my windows 10 laptop (64 bit) the webpages are as described above? Both chrome and IE look the same on each machine.

Perhaps related to the Java versions? The windows 10 laptop has Java 8 (64 bit) , and Java SE Development Kit 8 (64 bit) while the windows 7 laptop has java 7 (32 bit) and Java SE development Kit 7 (32 bit).

I can second Markus’ answer. This has been a problem with OH1.8 and empty labels. However, I think this was fixed in OH2. Anyhow, I believe this is linked to your items properties - either label or value.
How does the corresponding BasicUI look like?

The basic UI looks and works fine? Even when I reduce down to one item and a simple sitemap I have the same problem. Demo also gives same issue - with all other items files etc removed.

So while it may be an empty label or value, it doesn’t seem to be the problem. See my comment above - works fine on windows7/java7 laptop, just does work on windows 10/java * machine (at the same time)- so not related to items/sitemaps etc???

Any chance you can share the simple sitemap and one item config files you are using?

The demo sitemap/items files gives the same result - you can see these by selecting “demo”. I have deleted the actual files I used, but I have recreated them - without access to rpi to test.

#Items file
/* Data from MQTT */
Number Irms “Irms [%.1f A]” (log) {mqtt="<[OH2MQTT:home/rfm_gw/nb/node22/dev48:state:default]"}


sitemap Test label=“Test Sitemap” {
Frame label= “Main” {
Text item=Irms

The single sitemap example works fine for me, but so does the demo sitemap. How about a copy-paste of your whole sitemap so we can see what’s going on?

Hi Paul - thanks for looking into this. I don’t think the problem is an OH2 Configuration issue - as noted above if I look at the same site on my windows 7 pcs it looks fine. It only when I look at on my windows 10 pc it loses formatting. Incidentally if I look with IE on the windows 10 machine its fine but locks up after you click on the page.

Having said all that happy to zip entire directory of sitemaps/rules/items/cfg files etc and email to you. Whats your email address?

I’m happy to report that this problem is solved. I reinstalled Chrome on my laptop, and openhab2 now works 100%. Interestingly, I didn’t have any formatting issues with any other websites etc, just openhab2

Still very strange but happy to hear it’s working for you now!

Same Problem.

Windows 10 Chrome: horribly wrong formatting
Windows 10 IE11: bad but readable formatting
Android 6 Chrome: all fine

All other UI’s formatting work as they should. don’t work. 404

Thats it! Just clean the browsers cache and the problem is solved.