Classic UI has stopped working

My classic UI has stopped working … this is what I get …

HTTP ERROR 500

Problem accessing /classicui/app. Reason:

    Server Error

Caused by:

java.lang.NoSuchMethodError: org.eclipse.smarthome.ui.items.ItemUIRegistry.getChildren(Lorg/eclipse/smarthome/model/sitemap/Sitemap;)Lorg/eclipse/emf/common/util/EList;
	at org.eclipse.smarthome.ui.classic.internal.servlet.WebAppServlet.service(WebAppServlet.java:136)
	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:812)
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:587)
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(HttpServiceServletHandler.java:71)
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(HttpServiceContext.java:287)
	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(JettyServerHandlerCollection.java:80)
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
	at org.eclipse.jetty.server.Server.handle(Server.java:499)
	at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)
	at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
	at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
	at java.lang.Thread.run(Thread.java:748)


I have tried removing classic UI using paper UI and re-added it… but no differens…
Help is appreciated!

Did you try:

  • To restart OpenHAB;
  • To undo a recent change you have made to your sitemap? Maybe there are syntax-errors in your whatever.sitemap that you need to look in to.

Tried restart … have also tried undoing last change…no difference…

My sitemaps do work in the android app! Its just when using Classic UI that I get this error …

@Johan_F

I had similar problems; there is a new nightly available which seems to resolve my problems. Recommend to give it a try => #928.

ok! I will try that out… thanks

That actually worked! Thanks …

Cant understand why it suddenly broke in the first place though…

Hi I am facing the same issue. I assume there was a build for 2.1.0-snapshot-amd64, would it be possible to trigger a build for 2.1.0-snapshot-arm64 too?

Thanks!

Jan