Cleverio Thermometer Z-Wave issue - No XML file is created

I am trying to add Cleverio Thermometer. I gets added, but classified as “Unknown device”. I cannot find it in the database, so I though I added. But I do not get an XML file, and do not want to added it manually (due to error prone = noobi).

I have done factory reset of the sensor, re-added it a couple of times (read 4-5 times). No Luck!
I got another zwave sensor added to my openhab, so the z-stick works.

Do you know why I do not get an XML file?

  • Platform information:
    • Hardware: Raspberry PI 4
    • ZWave hub: Aeoech Z-stick gen5
    • openHAB version: 2.5.7

2020-08-02 13:48:54.012 [hingStatusInfoChangedEvent] - ‘zwave:device:4792ee89:node9’ changed from UNINITIALIZED to INITIALIZING

2020-08-02 13:48:54.026 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:4792ee89:node9.

2020-08-02 13:48:54.035 [hingStatusInfoChangedEvent] - ‘zwave:device:4792ee89:node9’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline

2020-08-02 13:48:54.038 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: MANUFACTURER not set

2020-08-02 13:48:54.039 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Controller status changed to ONLINE.

2020-08-02 13:48:54.040 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Controller is ONLINE. Starting device initialisation.

2020-08-02 13:48:54.048 [hingStatusInfoChangedEvent] - ‘zwave:device:4792ee89:node9’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE

2020-08-02 13:48:54.047 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Updating node properties.

2020-08-02 13:48:54.050 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:4792ee89:node9’ has been updated.

2020-08-02 13:48:54.053 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Updating node properties. MAN=2147483647

2020-08-02 13:48:54.055 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:4792ee89:node9’ has been updated.

2020-08-02 13:48:54.056 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Properties synchronised

2020-08-02 13:48:54.105 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:4792ee89:node9’ has been updated.

2020-08-02 13:48:54.106 [DEBUG] [ve.internal.protocol.ZWaveController] - Event listener added.

2020-08-02 13:48:54.108 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Initialising Thing Node…

2020-08-02 13:48:54.109 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Polling initialised at 1800 seconds - start in 1627200 milliseconds.

2020-08-02 13:48:54.110 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 9: Device initialisation complete.

If it is a battery device, it will need to wake up to complete initialization and to create the xml. Most devices will wake up on their own, but some do not. It will speed things up a lot to wake it up manually. The manual for the device should tell you how to do this. It’s usually a single or multiple press of the button used for inclusion/exclusion.

1 Like

I had trouble adding this device too.
With a fresh battery I finaly got it included.
But it could also be the restart that did it.
Check the battery contacts, they are a bit flimsy.

1 Like

Glad to hear that someone made it to work, the hope still remains :grinning:

I will check the battery contacts and change battery. Did you re-added after battery change? Restart, do you mean restart of system=raspberry or only openHAB?

I could not find anything in the manual about wake up. But I have left it on for three days, it should be the same as “wake up”, right?

However, still no luck for me. But I will check the battery thing and restart.

Any other recommendations or tips are welcome. Thanks for your tips!

Our database entry is here.

The text entered by a community member says it wakes up every 20 hours. One of the manuals attached says it wakes up every 300 seconds by default.

You might want to try excluding & re-including the device in the network. I do not normally suggest that but there appears to be no manual wakeup for that device.

Another option would be to remove the battery for 5 minutes & reinsert.

1 Like

To wake up the device use the pin in the hole, give it a push every two seconds when including.

And that pin is the only thing I still use. Not the sensor itself.
The sensor do work when included, but its build quality is not very good.

1 Like

If that works we need to update our database,

I gave up on this sensor last year, so it could be my memory that is faulty :slight_smile:

1 Like

I resemble that remark! :rofl: :rofl: :thinking:

Thanks for all ideas and tips!

  1. I checked the battery contact, looked fine.
  2. I bought new battery.
  3. Removed the sensor from the system and re-added it several times (read 4-5 times).
  4. I rebooted the Raspberry PI several times.

This without any luck.

Then I tried to the following 2 steps over and over again, many times (read 10ish times), without doing anything with the raspberry PI nor the zwave controller (Aoetec Z-Stick).

  1. Initiated the inclusion sequence (three clicks with 1.5 seconds).
  2. Direct after the LED indicating that the inclusion has started, single click every second, for 7-10 seconds.

AND finally I got the sensor initialised and recognised by OpenHAB!! Success!!

Now, I am not sure exactly with steps that made this to work. I have tried so many thing that I probably forgot some tries, but I think the last steps were crucial (so thanks @NilsOF of the tip) .

I hope this helps someone.


I used same procedure to “awake” Cleverio Door Sensor. 3 clicks to Include/exclude then tap every second to get update from database. Might need to be repeated a few times.

Door Sensor
Brand Name: CLEVERIO
Product Identifier: 51113

1 Like