Clocks and Times

Hi all,

I’m sure I’m missing something simple…

My PC and Docker, (I run OH in Docker), all say the time is 9:00
The ‘current time’ widget that I have on the overview page says 9:00

When I look at the logs and what both ‘now’ and the astro binding returns it is 8:00

I’ve checked the regional settings > time zone and have tried different settings and it seems to make no difference to the ‘now’ and ‘astro’ settings, I’m in the UK and have tried

GMT +1s
And various others to the point that I’ve tried and forgotten more than I can remember.

What’s missing in my setup or what is the correct settings please, it’s throwing all my time rules by an hour.

Recent post

You’ll be interested in your Java timezone, which is used for logging and scheduling in openHAB.

1 Like

Thanks, that pointed me in the right direction…I realsied that the docker container was missing a timezone…


  1. Stop the container
  2. Edit the container, find the Environment tab in Advanced Settings and add this entry.

NB - Pick your timezone from here: List of tz database time zones - Wikipedia and change the part after the = accordingly.

  1. Apply and Save
  2. Restart the container and marvel at the correct time.
1 Like