Cloudbees has stopped building

Looks like there’s an error on the server:

Started on Aug 25, 2015 3:01:00 AM
Using strategy: Default
[poll] Last Built Revision: Revision 1fb0c00f548e2581ff32e879d284eb349ad5b226 (refs/remotes/origin/master)
ERROR: Failed to record SCM polling for hudson.maven.MavenModuleSet@13413aa9[openHAB]

The last successful build was on 13th August.

thanks for letting us know. I’ve wiped out the workspace and started the build manually. Let’s whether this changes something …

Looks like it’s still broken. There’s nothing in the build history since 26th August - the one you started manually.

thanks Jon, i’ve created an issue at cloudbees since our Jenkins configuration seem to be ok! I’ll follow up as soon i’ll get an update.

Thanks, Thomas E.-E.

update: i received a response from the Cloudbees-Support which states that the problem should be solved now. Rootcause was most likely the update of their Dev@Cloud platform which caused a plugin incompatibility and we didn’t update the plugin accordingly.

We’ll see what happens tonight …

Looking good! Thanks Thomas.

Hi, @Kai, @watou, @steve1, @chris, @theo, @guessed, @hakan, @teichsta, @belovictor OH1 hasn’t built for 5 days now

@teichsta is taking care of this.
Meanwhile, the openHAB 2 build is still running nicely :slight_smile:

Yep, switched to OH2 permanently yesterday, was just waiting for the latest build of the MiLight binding to occur with the whiteMode pull request merged.
Very happy with OH2 now i’ve fixed/worked around all the niggles. Good work :smile:

I have restarted the OH1 build a few times, but it fails with$org.openhab.model.item/1093/console.
No idea, what this is about, is the build of the latest sourcing working for others locally?

Very happy with OH2 now i’ve fixed/worked around all the niggles. Good work :smile:

Thanks, glad to hear! I’ll soon also ask you to switch to the new Karaf-based distro at - so stay tuned!

i’ll have a look now …

A full build of master worked for me locally.

[ERROR] ExitStatusException occurred while running workflow: Java returned: 137
Exit codes above 128 mean that the java process was terminated via a signal, in this case it was 9 / SIGKILL (128 + 9 = 137).

Possibly killed by Jenkins because it took too long, or consumed too much RAM?

Any success?

unfortunately not with Cloudbees. As you probably know there is a second build server running (at innoQ) which builds the project without any problems (see

1 Like

+1 (locally)

So what does that mean? You are still on it? You gave up on it on suggest to move? You created a support ticket and are waiting for help from Cloudbees support?

yes, i am still on it and didn’t create a ticket (yet). I just want to reach out to them with a qualified issue report. I started a build yesterday (before going to sleep) which unfortunately didn’t succeed either. Meanwhile one could use the builds from the CI server.

1 Like

Short Update:

I’ve send a request to the Cloudbees Support who’s answered a minute ago:

You’re using small slaves, but the “small” slaves have only 1G memory, but your build is using a lot more, so our OOM killer stops your build. Please try using “standard” or “hi-speed” slaves instead of smalls.

Unfortunately it isn’t (yet) clear (nor documented - whether FOSS projects are eligible for standard slaves. The Cloudbees team will clarify this internally but most probably not before christmas.

Another Update:

The Cloudbees Support was so kind to configure the standard Slave for the openHAB build job which should solve the problem.

@kai, we’re over quota so probably Cloudbees will refuse the next build.
Mind spending another update ?

Your total DEV@Cloud disk usage is over your subscription's quota. Your subscription 'foss-free' allows 10 GB, but you are using 11032 MB across all services (Forge and Jenkins). To fix this, you can either upgrade your subscription or delete some data in your Forge repositories, Jenkins workspaces or build artifacts.