Comet Z not working out of box

Hi @chris let’s continue here …
(from )

I’ve reinstalled openHub2 because i was suspecting issues with the log system permissions.
Now the Node2 shows up with the same UUID as the uzb zwave stick …

any ideas what could be wrong - it even finds node 2 when the node 2 device has no battery in it …

Earlier i tried to create a copy of the device in the database, rename 2 labels and put the correct uuid into the entry, however now with the latest behaviour i feat that the devices uuid is picked somehow at random?!

Would appreciate any help - more than happy to document in case it would be easier to solve it offline …

PS I’m running the whole thing on a Synology in the /public/openHAB2 folder
it’s a version snapshot - (the latest one didn’t install)

That’s pretty unlikely I think - what are the UUIDs?

What ‘uuid’ do you mean? There is no ‘uuid’ in the database :confused:.

Please provide information / examples. At the moment it’s hard to work out what you are talking about.

Talking about

References (Type:Id)	4672:BD41

Ok, so these are just device references - UUIDs in the context of openhab are completely different.

Clearly the UUIDs of the two things are not the same in your image - right?

I changed back to v2.1.0.008 of OpenHub just to make sure it’s not a snapshot release messing up the things.
I’ve also added the following as comet.things into /volume1/public/openHAB2/conf/things/

<?xml version="1.0" encoding="UTF-8"?>
<thing:thing-descriptions bindingId="zwave"

  <thing-type id="eurotronic_cometz_00_000" listed="false">
    <label>CometZ Thermostatic Valve</label>
    <description>Thermostatic Valve</description>

      <channel id="switch_dimmer" typeId="switch_dimmer">
        <label>Openness Of The Valve</label>
          <property name="binding:*:PercentType">SWITCH_MULTILEVEL</property>
          <property name="binding:Command:OnOffType">SWITCH_MULTILEVEL</property>
      <channel id="sensor_temperature" typeId="sensor_temperature">
        <label>Temperature measured by the device</label>
          <property name="binding:*:DecimalType">SENSOR_MULTILEVEL;type=TEMPERATURE</property>
      <channel id="thermostat_mode" typeId="eurotronic_cometz_00_000_thermostat_mode">
        <label>Thermostat mode</label>
          <property name="binding:*:DecimalType">THERMOSTAT_MODE</property>
      <channel id="thermostat_setpoint_furnace" typeId="thermostat_setpoint">
        <label>Temperatur for Heat (Eco)</label>
          <property name="binding:*:DecimalType">THERMOSTAT_SETPOINT;type=FURNACE</property>
      <channel id="thermostat_setpoint_heating" typeId="thermostat_setpoint">
        <label>Temperatur for Heat (Comfort)</label>
          <property name="binding:*:DecimalType">THERMOSTAT_SETPOINT;type=HEATING</property>
      <channel id="battery-level" typeId="system.battery-level">
          <property name="binding:*:PercentType">BATTERY</property>

      <property name="vendor">Eurotronics</property>
      <property name="modelId">CometZ</property>
      <property name="manufacturerId">0148</property>
      <property name="manufacturerRef">4672:BD41</property>
      <property name="dbReference">372</property>


  <channel-type id="eurotronic_cometz_00_000_thermostat_mode">
    <label>Thermostat Mode</label>
    <description>Sets the thermostat mode</description>
    <state pattern="%s">
        <option value="0">Off (Frost Protect)</option>
        <option value="31">Manual (Valve Openness)</option>
        <option value="1">Heat (Comfort)</option>
        <option value="11">Heat (Eco)</option>


I’m not sure what you are trying to do with this - it is definately not a thing configuration? Please can you clearly state the issue, and what you are trying to solve. It started out that the database needed to change, now we are jumping between issues with UUID, and now to this so I’m getting confused as to what the problem is?

The initial problem was that the Comet-Z which is in the database was not recognized by OpenHub automatically.
After your advices i’ve downloaded the Thing configuration from your DB and changed

      <property name="manufacturerRef">4672:BD41</property>

This to some extend made it possible to read and set values on the thermosta using Paper-UI.

However it turned out that OH set the - i believe it was called “minimum polling period” - to something above 600K seconds. Therefore i tried to check the logfiles but they were all empty even though log level was set to debug for root logger. After these attempts were unsuccessful i reinstalled OH completly, now i added the controller again - works well - and tried to discover the “thing” with the same custom thing configuration as used before. However OH now always discovers the things as NODE2 but as unknown device. The weird thing is that it now also doesn’t show the manufacturer ref but instead states the name of the controller + a :node2.

Issues i would like to discuss here

  • I’m suggesting the manufacturer ref to be updated to the number stated above
  • I’d recommend changing the existing labels in the thing configuration in the database to better reflect their functionality
    talking about
      <channel id="thermostat_setpoint_furnace" typeId="thermostat_setpoint">
        <label>Temperatur for Heat (Eco)</label>


      <channel id="thermostat_setpoint_heating" typeId="thermostat_setpoint">
        <label>Temperatur for Heat (Comfort)</label>
  • last - but likely most important in order to proof that the suggestions i made are valid on this hardware - i would need support in adding the thing again
    • related to this issue i assumed that i need to remove the node from my network, however this functionality doesn’t seem to working either - or i didn’t understand how to do it

I’m not sure I advised to download this file? Where have you changed this? Are you now compiling your own binding?

I think I already stated elsewhere that you need to change the database back to the previous value, and then ADD (not change) the extra value that you added.


Well in regards to the download - that is the only way i found to immedeatly use the new thing without recompiling anything.

in regards to adding the value as opposed to changing it (besides not having the original value) i don’t have any option to put multiple values, i only have one field. That’s why i opted to copy the whole device and save it with a different number, but it looks like both got merged or overwritten somehow - sorry if that caused any trouble.
How would you state two different manufacturer references?

Last in regards to the labels,i’ve changed them online, however due to issues with my OH i can’t currently test the profile…

sorry i reached a max15 posts on 1st day limit therefore editing this one …

Please tell me what file you have put where

Following OH2 documentation any file called *.thing can be put into ./openHAB2/conf/things/
currently i have the file called comet.things in there - it’s a copy paste from your OH2 export of the database entry

comma separated manufecturer Type:ID

sorry i really didn’t check for mouseovers on a star next to the lines label … most of the page has a great useability therefore i thought the * meant it’s a mandatory field, not an explanation.
Do you still have the previous approved version? i believe it was 0000:0001 but i’m not sure and don’t want to add anything wrong.

manufacturer is the same

yes the manufacturer is the same and the manual and all other information on the page is also the same

recompile required

it didn’t require recompile earlier today, however i believe that the node was previously not part of my network yet and now it’s joined and therefore only treated as a appendix to my controller as opposed to a unique thing.
Furthermore i see the main issue that OH is sometimes showing error 500 - in particular when changing config parts of a thing - might be related to the recompile / manual direcotry thing overwrite though.

At present the problem is that the thing is not correctly identified even though i put the correctly updated file into the folder like before. It almost seems like the controller caches the node because it also shows the node when the device itself which is represented by node2 is switched off

If you’ve not recompiled anything, then please describe what you’ve actually done as I don’t understand. Sorry. It’s not possible to update the database without recompiling the binding.

Please tell me what file you have put where - I suspect that whatever you have done has not actually changed anything at all.


The manufacturer is the same thought, right? It’s just the device type and ID that are changing? Or is this really a new manufacturer as well?

You need to recompile the binding for this to take affect. Maybe this is why you think OH has a problem?


(I use openHAB 2.1.0 - release build -)

i guess my problem could be related to a wrong entry at the database.
On my Comet Z, i can’t set the value for “Eco mode” temperature. I use this channel “zwave:device:controller:node4:thermostat_setpoint_furnace”.
But i can set the “Comfort mode” temperature by using the channel “zwave:device:controller:node4:thermostat_setpoint_heating”.

And i am confused by the name furance in the channel name, because my Comet Z has 3 entries for the COMMAND_CLASS_THERMOSTAT_SETPOINT :

  • one for eco mode
  • one labeled “Furnace”
  • one for comfort mode

The command with the “Furnace” label don’t work at all. And thats why i suggest that the “zwave:device:controller:node4:thermostat_setpoint_furnace” channel is linked to the command
labeled “Furnace” and not to the command for eco mode.

Here is the entry the command Classes with i got out of the open-zwave-controller-panel controler confuguration XML:

<CommandClass id="67" name="COMMAND_CLASS_THERMOSTAT_SETPOINT" version="1" request_flags="4" innif="true" base="0">
  <Instance index="1"/>
    <Value type="decimal" genre="user" instance="1" index="1" label="Comfort setpoint" units="C" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="25.0"/>
    <Value type="decimal" genre="user" instance="1" index="7" label="Furnace" units="C" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="0.0"/>
    <Value type="decimal" genre="user" instance="1" index="11" label="Energy saving setpoint" units="C" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="20.0"/>

Some help to get the setpoint for Eco to work would be great.

I could also be totally wrong because i’m totally new to openhab