Command received with no implementation (QuantityType)

Just wondering if anyone has had this error before just by sending a device(zwave) a status update?

I have a bunch of simple sends that happen when other events happen and I realized today that none of those events seem to be working. Checking things out I am doing this in a rule :


Which results in this :
23:27:06.959 [ERROR] [nding.zwave.handler.ZWaveThingHandler] - NODE 95: Command received with no implementation (QuantityType).

Any ideas?

I assume your item is a ColorType.
And the system can not distinguish what you try to achieve when setting this value. To properly set a colorType you would need to define the type of the value so the system knows what you like to achieve, e.g. setting it to 3 percent.

Please refer to the documentation on how to properly set this.

Section “Using the States of Items in Rules”

It’s not. I’m actually setting the color of the HomeSeer 200 dimmer, which has I think 7 values(0-7). This worked in the past, and worked for a few months but now none of them work.

What version of the zwave binding are you using and which device? I believe this was reported and resolved, so you may need to update the binding.

240 │ Active │ 80 │ │ ZWave Binding

As far as I can tell, latest and greatest.

And I’m sorry, this is the HomeSeer HD-200+'s, I have 26 of them which all do the same thing. I’m simply setting one of the status LED’s on the unit to a color when there is motion in the room. (sort of an indicator that motion was detected).

Check through those threads. I’ve browsed them but didn’t read them thoroughly. I thought I saw this as resolved, but I’m not sure if that involved both a binding update and an update to the device. Actually, it looks like it may have been for temperature. I bet @chris knows. :slight_smile:

Yea, that’s for number. I have these items set to Number:Dimensionless, as I don’t know what else I would set them to. I guess I’ll play around in that area and see if I can guess what it’s supposed to be. Maybe Chris knows, that’d be great!

What binding are you using? Is it the development version, or the current master snapshot?

I would think that’s development as it’s from 7/23.

Figured it out, I think. It’s the dimensionless setting. Once I remove that things start working the way they are supposed to again. When I first got these, I didn’t have the option to leave that blank, so I had to pick something. I see now that is changed, so I can just have it be a number with no dimension setting.

Thanks for everyone’s input, it’s appreciated!

1 Like

Did you install it through PaperUI? If so and with that date, it would be a snapshot. Development is available here and installed by dropping it into the addons directory.

Okay, then certainly snapshot. I would put in the development, but I just don’t have the time to remove and re-add all my things. I have over 100 zwave devices, so that would take a bit.

I just ask Alexa to do it… :wink: